[Resolved] you search for language

Home Forums Support you search for language

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #106489
    Liana Ghazarian

    Hi Tom,

    I would like to change the language for “you searched for” to Armenian. I already have created a plugin and with your code changed the language of the word “search”. Can you help me, please?

    #106507
    Tom
    Lead Developer
    Lead Developer

    Hi Liana,

    Do you mean the “Search Results for:” text?

    This text is translatable – all you have to do is download Poedit: http://poedit.net/

    Then open the generatepress.pot file found in the “languages” folder inside Poedit.

    You’ll find the above text which you can then translate to Armenian.

    Then save the translation as ar.po, and upload it to your languages folder.

    You can then send me the translation to support@generatepress.com, and I’ll make sure it’s in the next version by default 🙂

    Let me know if you need more info!

    #106959
    Liana Ghazarian

    Hi, great I can change now. I have a question though. When the text is

    Search Results for: %s

    The translation should be

    XXX:%s

    or just XXX

    #106968
    Liana Ghazarian

    Hi, Tom, I did as you said, there are no ar.po and ar.mo in the languages. But the arm language doesn’t show yet. How should i activate it?

    #106999
    Tom
    Lead Developer
    Lead Developer

    You should match is exactly, so:

    Search Results for: %s

    Would become:

    xxx: %s

    If you’ve added the language files to the languages folder in generatepress, then your changes should apply if you have your language set in “Settings > General” at the bottom.

    Also, I’ve submitted 1.2.9.6 to WP.org, when they approve it and push out the update, it will remove your language files from the generatepress/languages folder. Be sure to back up your files before you update, and re-add them once the update is completed.

    #107036
    Liana Ghazarian

    Hi, Tom, my language is not supported by wordpress (it doesn’t figure among possible languages in settings/general). Does it mean I cannot change the text using this method?

    #107078
    Tom
    Lead Developer
    Lead Developer

    Try adding this into your wp-config.php file:

    define ('WPLANG', 'hy_AM');

    #107125
    Liana Ghazarian

    Great.

    I pasted the code above in wp config (which brought my site down, then some googling which taught me that the last line shouldn’t be an empty line in wp confing, so erased it and the site was working again). Then I renamed the files to hy_AM. and hy_AM.mo, put then in languages folder, chose hy_AR from the dashboard and that is it.

    #107184
    Tom
    Lead Developer
    Lead Developer

    Great!

    When you update GeneratePress, you will need to re-add your language files to the languages folder.

    To prevent having to do this, you can:

    a) Send me the files to include in GeneratePress by default – 1.2.9.6 has already been uploaded, so you would have to re-add them once, but they would be added by default in 1.2.9.7.

    b) Add your language files to your child theme: https://codex.wordpress.org/Function_Reference/load_child_theme_textdomain#Example

    Let me know if you need more info 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.