[Resolved] WP Dashboard says "PHP update required"

Home Forums Support WP Dashboard says "PHP update required"

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1066778
    Daniel

    I am running GP 2.3.2 under PHP 5.6.40. I contacted my ISP, Bluehost, about this error message and they said they tried to update me to PHP 7.x, but my theme is not compatible with current versions of PHP. What should I do?

    #1066786
    Leo
    Staff
    Customer Support

    Hi there,

    Not sure where your host got that info from but GP is always compatible with the latest version of PHP and so definitely upgrade.

    Let me know if this helps 🙂

    #1066790
    Daniel

    Strange. I’ll try again with Bluehost, but they were quite certain it was “my theme” causing the problem. Perhaps it’s another theme that is functioning elsewhere under my Bluehost account.

    #1066792
    Leo
    Staff
    Customer Support
    #1067633
    Daniel

    I’ve spent hours on chat with Bluehost, and am stumped. I have four sites, all on the same Bluehost account and all running identical current versions of WordPress and GeneratePress. Two sites update to PHP 7.2 just fine, but two cannot update past PHP 5.6 without creating 500 errors when viewed.

    If it’s helpful, here are the sites that update fine: danhotchkiss.com, congregationalconsulting.org. Here are the ones that do not: calvinhotchkiss.com, solsticesingers.org.

    Any ideas what I can do next to avoid getting stuck with old versions of PHP forever?

    Thanks,
    Dan

    #1067677
    David
    Staff
    Customer Support

    Hi there,

    if the site is 500’ing then the host should be able to provide an error_log which should give some indication as to what is causing it. I would begin with looking at any ‘old’ plugins.

    #1067684
    Daniel

    Great advice, thank you!

    #1067704
    David
    Staff
    Customer Support
    #1102325
    Daniel

    Just a follow-up for the possible benefit of others. Bluehost insists that they cannot update me beyond PHP 5.6 because of an incompatible code in a theme or plugin. I’ve inactivated all plugins, tested using the PHP Compatibility Checker plugin (which lists the GeneratePress plugin compatibility with PHP 7 as “unknown” because it is too large to scan), and spent hours on chat with Bluehost.

    No result! I’ve reverted to PHP 5.6 and decided to live with it.

    Dan

    #1102342
    David
    Staff
    Customer Support

    GP and GPP is 7.x compatible as you can tell from your other sites.
    If you go to Dashboard > Tools > Site Health do any issues show up there? Such as outdated plugins?

    Bluehost should been able to pinpoint the cause of the 500 error……

    #1102363
    Daniel

    Thanks for this suggestion!

    In Tools->Site Health I see a warning that my PHP version is 5.6.40 and requires an update. In addition, I see:

    A suggestion to remove inactive plugins.
    A suggestion to remove inactive themes.
    A warning that “The optional module, libsodium, is not installed, or has been disabled.”

    Are any of these likely to be part of the problem? I know how to follow the first two, but have no idea how to follow the third.

    Dan

    #1102389
    David
    Staff
    Customer Support

    I would begin with removing the inactive plugins and themes as they may be hiding the culprit.
    The libsodium module is a server side installation – so your host would be responsible for handling that ….

    #1103393
    Daniel

    Happy ending, after many hours spent. I finally got a chat tech at Bluehost who could fix the problem by adjusting the .htaccess code in each site. For what it may be worth to others, here is the full text of one .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    # php — BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php73” package as the default “PHP” programming language.
    <IfModule mime_module>
    AddHandler application/x-httpd-ea-php73 .php .php7 .phtml
    </IfModule>
    # php — END cPanel-generated handler, do not edit

    #1103627
    David
    Staff
    Customer Support

    Glad you found a tech guy who knew what he was doing 🙂

    #1103652
    Daniel

    Gal. And yes.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.