[Resolved] WooCommerce Pages Display Right Sidebar at Bottom of Page

Home Forums Support WooCommerce Pages Display Right Sidebar at Bottom of Page

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1329004
    Brian

    I am starting to build a WooCommerce website right now and am running into a problem with GeneratePress Premium. The WooCommerce Shop and Product pages are set to have a Sidebar on the right side, but it shows up below the Product display. I’m not sure what to tweak to get it to display correctly. They display perfectly on the Woo Storefront theme.

    Thanks.

    Brian

    #1329131
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can link us to the site in question?

    You can edit the original topic and use the private URL field.

    Let me know 🙂

    #1329177
    Brian

    Done. It is a staging site, but I think you should still be able to access it. I put the link to a Category page, where it is most obvious. You’ll see below the category the list for Shop Artwork by Subject. That is a widget on the Right Sidebar (Layout > WooCommerce > Shop > Sidebar Layout > Content/Sidebar. Single Product also set to Content/Sidebar), but it displays below all the Shop, Product, and Product Category pages. This is a site under development, so there are only six products in it (for testing purposes). Thanks. I appreciate you taking a look at it. There was some issues with the main body/container for those same pages being very narrow too, but I think I solved that one. Although not sure I solved it the right way. I can’t even remember what I did, but I think I changed the number under Layout > Container > Container Width to 1200. Can’t remember what it was, but it was very narrow.

    #1329362
    Leo
    Staff
    Customer Support

    I’m seeing this CSS which is causing the issue:
    https://www.screencast.com/t/xRfwYJtng

    Can you remove that?

    #1330167
    Brian

    I am not sure which css you are referring to (my coding skills are very rusty, and my WordPress skills are a total Newbie). Is it the red boxed code on the right side of the image, or the highlighted blue line of code on the left side? I searched for both and didn’t find any matches. I looked in both wp-content/themes/generatepress/css/admin/style.css and wp-content/themes/generatepress/style.css but neither files seems to be the one displayed in your image.

    Brian

    #1330182
    Leo
    Staff
    Customer Support

    Yup that’s the CSS I’m referring to.

    It won’t be the GP’s style.css files as it’s not CSS coming from GP.

    Can you disable SiteGround optimizer? Then I might be able to tell where it’s coming from.

    #1330192
    Brian

    I’ve Deactivated the SiteGround Optimizer plugin. Hopefully that helps track it down. Thanks.

    #1330302
    Leo
    Staff
    Customer Support

    Looks like you’ve fixed it?
    https://www.screencast.com/t/aKwyT4oya9

    I no longer see the issue.

    #1330433
    Brian

    Hmmm … all I did was Deactivate the Siteground Optimizer plugin. So apparently there is a conflict with that plugin. I will go through all the settings and see if I can figure out what it it. Strange it doesn’t conflict with the other themes I’ve tried (Storefront and Astra free version). But that’s computers for you. Thanks for helping track down the conflict at least. Not sure where I’ll go from here.

    #1330434
    Leo
    Staff
    Customer Support

    Does the issue come back if you activate the SG Optimizer again?

    Could just be a caching issue.

    #1330435
    Brian

    Yes, I just turned SG Optimizer back on to verify that is the issue, and it’s back to original behavior. Right Sidebar displays below main content. So it is definitely a conflict with some setting in SG Optimizer. I will look at the caching settings first.

    #1330446
    Brian

    Found the culprit – it was the Minify CSS Files setting. I turned it off and the problem went away. Right Sidebar displaying properly.

    Here is the setting:

    Minify CSS – Minify your CSS files in order to reduce their size and reduce the number of requests to the server.

    Found here:

    SG Optimizer > Frontend Optimization > Minify CSS Files (turn off = it works!)

    Thanks for help in solving the problem. Without your input/insights I never would have even thought to look there.

    #1330451
    Leo
    Staff
    Customer Support
Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.