[Resolved] Weird page edit issue

Home Forums Support [Resolved] Weird page edit issue

Home Forums Support Weird page edit issue

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1584914
    Mike

    Hi, I am trying to track down one issue… I don’t even know if this is it… but I need to discount it so…
    Disable GenerateBlocks plugin -> go to PAGE -> EDIT -> DO NOTHING -> Back Out… all good.
    Enable GenerateBlocks plugin -> go to PAGE -> EDIT -> DO NOTHING -> Back Out… ‘UNSAVED CHANGES WARNING’.
    So something fishy is happening.
    My actual problem is this:
    [Mon Dec 14 14:41:00 2020] [error] [client 109.249.185.81:0] AH01075: Error dispatching request to :
    [Mon Dec 14 14:41:00 2020] [error] [client 109.249.185.81:0] AH01067: Failed to read FastCGI header
    Which is usually dodgy PHP code. I’ve checked ALL code and at least it doesn’t report errors… I’ve tried theme switching / plugin disable etc. It’s an intermittent error so very hard to know when cured.
    So I’m left hoping the two errors are related and maybe there’s a bug in your blocks plugin?
    Could you have a sniff and let me know if you see anything.
    I’ve duplicated the site to a publicly accessible staging area – so you can have credentials and play if you wish.

    #1584972
    Leo
    Staff
    Customer Support

    Hi there,

    I tried to replicate the issue on my install but unable to do so.

    Can you take a look at the screen capture below and let me know if this is what you meant?
    https://www.screencast.com/t/40OAxsjDR

    Let me know 🙂

    #1584974
    Mike

    Ok… so probably not related. I managed to track it down to a reusable block. Once I went to ‘manage all’ and renamed the block + re-save… the strange ‘UNSAVED CHANGES’ error disappeared.
    Sigh!!
    There’s definitely something funky going on with reusable blocks, but I think that a WP core issue.

    So I just have to track down whatever is causing the ‘Failed to read’ and triggering 503s…

    #1584988
    Leo
    Staff
    Customer Support

    Thanks for reporting back!

    #1585003
    Mike

    No problem.
    Maybe no-one else will experience this… but for me – upgrading to the latest WP broke two of my reusable blocks.
    The first one caused pages to demand saves despite no changes (yes, as per your video).
    The second caused a 503 / Failed to read FastCGI header – error – when browsing the site / wp-admin, all manner of odd places… and I had to delete the block entirely.
    It seems to have resolved all the issues except my new headache!
    Hope it helps someone.

    #1585004
    Mike

    Oh… and it occurs to me that a new site in which I imported one of your ready made themes experienced issues. Whatever has changed about the block editor it may affect this too?

    #1586639
    Leo
    Staff
    Customer Support

    Sorry is this a new issue now?

    #1586818
    Mike

    No. I hate when a support thread just says “don’t worry, I fixed it” without actually saying how! So I’m just feeding back that there is definitely something shonky with the block editor in the latest WP / GP (I think it’s a WP issue) – simply re-saving reuseable blocks helps, but sometimes thats not enough – and the issue can affect the site in all manner of weird places. Since your pre-made themes often include reuseable blocks it might be an issue to look out for.

    #1587448
    Tom
    Lead Developer
    Lead Developer

    Which site from the Library had the issue? I’ll take a look, as none of those should have re-usable blocks.

    This is a block editor issue when a reusable block has deprecated blocks inside of it. Those blocks need to be saved in order to update to their new versions before the reusable block is usable.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.