[Resolved] website error log

Home Forums Support [Resolved] website error log

Home Forums Support website error log

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #637934
    Patricia

    I’m receiving the following error message in my website error logs every time an order is placed through the Woocommerce plugin. I’m trying to track down the source of the error. This error doesn’t effect order processing. Orders from Woocommerce are still go through just fine. I’ve contact Woocommerce about this error and they say it is related to the GeneratePress theme configuration. Do you think this error is related to GeneratePress? Can you please take a look. Thanks!

    Website error log message:
    payment_method_title was called incorrectly. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::do_wc_ajax, do_action('wc_ajax_checkout'), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::checkout, WC_Checkout->process_checkout, WC_Checkout->process_order_payment, SkyVerge\WooCommerce\PluginFramework\v5_1_5\SV_WC_Payment_Gateway_Direct->process_payment, WC_Order->payment_complete, WC_Order->save, WC_Order->status_transition, do_action('woocommerce_order_status_pending_to_processing'), WP_Hook->do_action, WP_Hook->apply_filters, WC_Emails::send_transactional_email, do_action_ref_array, WP_Hook->do_action, WP_Hook->apply_filters, WC_Email_New_Order->trigger, WC_Email->get_content, WC_Email_New_Order->get_content_html, wc_get_template_html, wc_get_template, include('/plugins/woocommerce/templates/emails/admin-new-order.php'), do_action('woocommerce_email_order_details'), WP_Hook->do_action, WP_Hook->apply_filters, WC_Emails->order_details, wc_get_template, include('/plugins/woocommerce/templates/emails/email-order-details.php'), do_action('woocommerce_email_after_order_table'), WP_Hook->do_action, WP_Hook->apply_filters, wc_add_payment_type_to_emails, WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong. This message was added in version 3.0.

    GP Premium 1.6.2
    #637953
    Leo
    Staff
    Customer Support

    Hi there,

    That doesn’t look like a GP error. We haven’t had this reported either.

    Can you try switching to a default Twenty-series theme and see if the error shows up there?

    Let me know ๐Ÿ™‚

    #638007
    Patricia

    I switched to the Twenty Fifteen theme, ran an order and the error still shows up. I just wanted to check with you to see if there are things that may still be running with GeneratePress even without the theme being enabled. I’ll go back to Woocommerce on this issue. Thanks.

    #638165
    Leo
    Staff
    Customer Support

    Yeah that case should be error from their end.

    Let us know what they say if you don’t mind so we can help the next customer ๐Ÿ™‚

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.