[Support request] URL sent not found (404)

Home Forums Support URL sent not found (404)

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1024249
    Paolo Fauci

    Hello

    This morning Google Console sent me an alert with this error:

    URL sent not found (404)

    I went into my account and found this long list of pages that are not found.

    https://prntscr.com/pdw9mt

    Page 404 is working fine because it has been translated and the search has been removed and a lunk has been added to HomePage.

    Why are “keywords” seen as pages?
    How can I solve this problem?

    How can I solve this problem?

    I’m waiting for your instructions
    Thanks
    Paolo

    #1024734
    David
    Staff
    Customer Support

    Hi there,

    i can’t see how this is related to the Theme.
    I am unable to visit your site as once again i am getting a 403 error.

    #1024956
    Paolo Fauci

    Hi David, this is not the first time you get this error 403.
    As mentioned in previous messages, your IP address has probably been entered in the Black List.
    So if you give me your IP Address I will remove it once and for all. Thanks

    I have never received this kind of error from the Google Console.
    As I wrote to you this is “some of the keywords on my site” are not pages.

    1- Can seo Yoast settings be a problem?

    2- page 404 is working, why does Google Console send this error to me?

    This is a screnshoot of the url I sent you

    https://prntscr.com/pe7bds

    I await your news
    Thanks
    Paolo

    #1025045
    David
    Staff
    Customer Support

    I work remotely on a dynamic IP so unfortunately i cannot.

    Keywords being indexed as pages – this is beyond me, best to speak with Yoast.

    To the best of my knowledge Yoast sets the 404 page to noindex. If you have created a custom 404 or redirect then you may want to check that is set to noindex.

    #1025084
    Paolo Fauci

    Hi David ok for IP address

    For page 404, if you remember, I had opened a ticket to customize GeneratePress page 404.

    What I did was to go the 404.php file and I made some changes translating the text from English to Italian, removing the “search” and putting the link to the home.

    However, today I am reading this on the php file

    The template for displaying 404 pages (Not Found).

    https://prntscr.com/pea62t

    I didn’t create any 404 page, I simply modified the 404.php file

    I didn’t create any redirection.

    Can you give me clarification on this?

    Can you help me create a 404 page if you believe this solves the problem? Thanks

    Because the error reported by Google Console refers to this:

    URL sent not found (404)

    for the pages associated with the Keywords

    Before on my site I used the Bimber theme and never had this kind of problem.

    I await your news
    Thanks
    Paolo

    #1025113
    David
    Staff
    Customer Support

    I am not sure how this is theme related, GP doesn’t do anything regarding the permalinks or indexing of the site.
    Can you share the Search Console error link and i’ll take a look.

    #1025135
    Paolo Fauci

    The link of a page that is reported is the one I have already sent you

    this is the Search Console screen

    https://prntscr.com/pdw9mt

    let me know if you need anything else
    Paolo

    #1025786
    Tom
    Lead Developer
    Lead Developer

    All of your screenshots seem to have have been removed.

    It’s possible that your sitemap (generated by Yoast) has some wrong entries. Have you checked with their support?

    Changing the 404 template shouldn’t cause any issues.

    #1025835
    Paolo Fauci

    Hi Tom, hi David

    on David’s advice yesterday I tried to contact Yoast support.

    After several attempts I managed to find the problem.

    In the site map I also entered the keywords.
    Yoast suggests this: a 404 is shown when there is no post linked to the keyword.

    The problem was that many of those keywords were associated with a post already published.

    After several tests suggested by Yoast I found the problem in the wordpress settings => Permalink basic tag keyword.

    As soon as I modified this basic tag, the pages was immediately available.

    Now my doubt is what this change entails?

    Changing the basic Tag keyword also involves changing the url.(relative to only the keywords)
    What kinds of problems can I have in the future?
    Normally I share the URLs of the Post and never those of the archives or tags.
    I am waiting for clarification from Yoast

    Thank you very much for your assistance

    Good day
    Paolo

    #1026294
    Tom
    Lead Developer
    Lead Developer

    Hi Paolo,

    I think Yoast might be able to answer that question better for you. I’m not sure what you mean by the tag keyword? Were you not using one of the standard permalink options?

    #1026313
    Paolo Fauci

    Hi Tom I was not using this setting

    https://prntscr.com/pej5l4

    I’m waiting for yoast to respond.

    Thanks

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.