[Resolved] Unable to remove widgets with customizer

Home Forums Support [Resolved] Unable to remove widgets with customizer

Home Forums Support Unable to remove widgets with customizer

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #262160
    shihanluis

    Hey Tom, we were talking last night via email. Just ran into an issue with GP Premium. I’ve been trying to remove widgets with the customizer, specifically the footer widgets, but it just doesn’t allow me. I tried doing it within appearance–>widgets and it doesn’t work either. When I disable GP Premium I can manipulate the layout with no issues. Any ideas? It’s a brand spanking new site so there is not much in there, just trying to use the add-ons to manipulate the layout.

    List of plugins installed:

    1. Contact Form 7 – to make the forms.

    2. Flamingo – to store the contact list on WordPress

    3. Image Watermak WP – make watermarks

    In case there might be a conflict with any of the plugins, that’s what I have installed. But I disabled them one by one and all worked well. Except when I enable GP Premium I can’t manipulate GeneratePress widgets.

    Thanks

    #262205
    Tom
    Lead Developer
    Lead Developer

    Are you trying to remove the widget placeholder text? If so, the only way to do that is to add your own widget into the area.

    Let me know ๐Ÿ™‚

    #262341
    shihanluis

    No am not trying to remove the widget placeholder text. When I disable a widget from a sidebar, I get an internal server error. If I delete a page and remove the menu item for that page, I get the same error. The only way to fix it is by disabling GP Premium. As if something in the database gets corrupted after using the customizer. I checked the address bar and it seems to be hinting at the plugin when I get the error:
    return=%2Fwp-admin%2Fplugins.php%3Fplugin_status%3Dall%26paged%3D1%26s.

    Something is making it crash. Yet it happens even if I don’t have any other plugins installed. I even re-installed wordpress and recreated the layout. If I try deleting a page and try to go back to customize the same thing happens again.

    Any help much appreciated.

    #262469
    Tom
    Lead Developer
    Lead Developer

    Databases very rarely get corrupted, I doubt it’s that.

    The URL you’re seeing is WordPress telling the browser to return to the page you were previously on.

    Internal server errors can be a bunch of things – you need to check your error_log file to get a specific error. You can ask your hosting where it is if you don’t know.

    In most cases, it’s a PHP memory limit thing which you can fix: https://docs.generatepress.com/article/increasing-php-memory-limit/

    #262572
    shihanluis

    Hey Tom, yes that url sends me back to where I was which was the customizer which returns with the said error. I found the culprit though. The error was with Jetpack.

    I tried the below code in wp-config.php. If anyone else is following along, you must remove define(‘WP_DEBUG’, false); if your config file has it already. Then check the log file it generates for details.

    define( ‘WP_DEBUG’, true );

    if ( WP_DEBUG ) {

    @error_reporting( E_ALL );
    @ini_set( ‘log_errors’, true );
    @ini_set( ‘log_errors_max_len’, ‘0’ );

    define( ‘WP_DEBUG_LOG’, true );
    define( ‘WP_DEBUG_DISPLAY’, false );
    define( ‘CONCATENATE_SCRIPTS’, false );
    define( ‘SAVEQUERIES’, true );

    }
    I found out in the log that some files were missing from the jetpack installation thus causing the error 500.
    The solution was to completely delete the jetpack plugin and manually upload it. This has seem to work fine.

    Thanks for the replies though.

    Cheers

    #262638
    Tom
    Lead Developer
    Lead Developer

    Glad you got it working ๐Ÿ™‚

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.