[Support request] Unable to Change The Copyright Message

Home Forums Support Unable to Change The Copyright Message

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #1057601
    cnetplanet

    Hi

    I am using GeneratePress Premium and the Copyright add-on is activated under Appearance > GeneratePress.

    I am adding the text here at Customize > Layout > Footer > Copyright and click publish – and I could see that the preview on the right hand side is change and Copyright Message is updated.

    But then I am seeing the same default Copyright message “Site Title – Powered by GeneratePress” as soon as I refresh the page and check the site. And when I check at Customize > Layout > Footer > Copyright, I am not seeing the text I added a few seconds ago.

    Not sure why it’s happening – could someone please help me with this?

    Thank you

    #1057946
    David
    Staff
    Customer Support

    Hi there,

    what happens if you just add a single word, no HTML or links in the copyright ? Does it save?

    #1058132
    cnetplanet

    Hi David,

    I just tried adding the simple text (no HTML and no Links) in the copyright and it saved and it worked.

    But when I tried entering the text with HTML and Links and refreshed the page, it didn’t save and switched back to the previous text only version. Looks like text with HTML and Links is not sticking in the Customize > Layout > Footer > Copyright section.

    Any idea how to fix this?

    BTW, I am using GPP on another site and the similar code works but not on this site. I am working on a staging environment because I am changing the site theme from Enfold to GPP. Not sure if it should matter though.

    Thank you

    #1058134
    Leo
    Staff
    Customer Support

    That’s weird. This is what I’m seeing currently and it isn’t the default message.

    So did it work before?

    Can you disable all plugins except GP premium to eliminate any unknown conflicts?

    If that doesn’t help, can you copy and paste the HTML content you are trying to add here?

    Make sure to highlight the code and click the code button in the editor.

    #1058154
    cnetplanet

    Hi Leo,

    What you showed in the screenshot is just plain text without any HTML codes and links. Looks like plain text works and it is not saving anything with the HTML and Links.

    I tried disabling plugins one by one but it didn’t work.

    I am trying to add this text

    —————————————————————-

    %copy% %current_year% Copyright - <a href="http://domainname.com/">Best Truck Upgrades</a> | <a href="http://domainname.com/about-us/">About Us</a> | <a href="http://domainname.com/contact-us/">Contact Us</a> | <a href="http://domainname.com/terms-of-service/">Terms Of Service</a> | <a href="http://domainname.com/disclosure-and-privacy-policy/">Disclosure & Privacy Policy</a>

    —————————————————————-

    P.S. – Can you also please delete the Screencast screenshot? Thank you

    #1058156
    cnetplanet

    David previously suggested to test the plain text without using any HTML and URLs, and check if it works.

    Maybe he has seen this happening before and knows the fix to this issue.

    #1058182
    Leo
    Staff
    Customer Support

    I just copied and paste your code and was able to get it to work no problem:
    **Deleted

    Instead of disabling the plugin one by one, can you disable them all at once and see if the issue still exists?

    If so can you leave the plugins off and provide the dashboard access?

    You can send the dashboard access using Account Issue here:
    https://generatepress.com/contact/

    Please include the following information:
    – The URL of this topic.
    – Login URL.
    – Username and password.

    #1058290
    cnetplanet

    Thanks Leo,

    I think for now I will just leave the Copyright footer note as is without any links and continue working on the site.

    I am also curious to know if David has seen this before and knows the fix? Maybe you could somehow tag him or assign this ticket to him.

    —————————————————————-

    P.S. – Can you also please delete the Screencast screenshot? Thank you

    #1058359
    David
    Staff
    Customer Support

    I deleted the screenshot.
    Thoughts were either some funky HMTL or WP didn’t like the links. So chances are it didn’t like the links. Did you use the real domain URL with HTTPS ?

    Personally i would look to use a Nav Widget in the footer may require a little CSS for alignment.

    #1058373
    cnetplanet

    Thanks Davin,

    That actually makes sense and could be the case – I used URLs from a live website but on a staging site.

    I want to change the theme of a live site, from Enfold to GPP, but instead of working on a live site I am doing this on a staging site. I used the URLs from the live site in the copyright section of the staging site. That could be the reason.

    I will migrate GPP site to the live site in the next few days, so I will try adding links in the Copyright section at that time.

    Thank you again!

    #1058380
    David
    Staff
    Customer Support

    Well lets hope thats the case 🙂 Glad to be of help.

    #1059772
    Joao

    Hi there, I’m new here so let me start by congratulating you on GP. Well done.

    Now, regarding the issue copyright message:
    . I’m using WPML and I have a website in Portuguese (default lang changed to pt (pt)). I’m translating it into EN, FR and ES.
    . My footer copyright message was
    doiton.agency %copy%%current_year% | Privacidade
    So, I needed to change the URL linked to the word Privacy (and the word privacy was also different for each language (privacidad, privacidade and confidentialité for ES, PT and FR)).
    . I followed this procedure: https://wpml.org/forums/topic/translating-footer-copyright-text/ (and was able to find the string to be changed).
    . There was an issue: Despite having my website in PT, having my theme translated into PT (just another point in favor of GP), footer customiser in GP is, unexpectedly, linked to the EN page. This meant changing the copyright message in customiser to:
    doiton.agency %copy%%current_year% | Privacy

    Not the easiest solution but it works when using WPML.

    Best,
    J

    #1059786
    Leo
    Staff
    Customer Support

    Any chance you can open a new topic for your question?

    Thanks 🙂

    #1059793
    Joao

    Hi, no question here. Just sharing. You can edit the copyright message without much ado.
    I’m happy with GP.

    (You may/may not want to check the customiser thing…)

    #1059795
    Leo
    Staff
    Customer Support

    Ahh ok my bad.

    Thanks for sharing!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.