Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Typography (Font Family) issue in Firefox

Home Forums Support Typography (Font Family) issue in Firefox

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #174531
    Mo

    Hi Tom,
    The typography add-on seems to have issues with Firefox (v44.0.2).
    When adjusting the controls for any of the sections, (Body, Header. Navigation, etc.) the only changes resulting from the adjustments are to the font weight, font size and text transform.
    What doesn’t change is the font family.

    The typography add-on works flawlessly in IE (v11.0.28) and Chrome (v48.0).
    It wasn’t until I checked in these two browsers that it became clear that the font family was not affected in Firefox.

    Just to make certain it wasn’t a Firefox add-on, Firefox was restarted in safe mode, disabling all add-ons.
    This made no difference.

    Any ideas?

    Thanks,
    Mo

    #174554
    Tom
    Lead Developer
    Lead Developer

    Hi Mo,

    So when you change the font family in Firefox, nothing happens? Does this happen with all of the font family options?

    I just tried it in Firefox and everything works as it should.

    Maybe you have a plugin causing the issue? Can you try #1 on this page?: https://generatepress.com/knowledgebase/debugging/

    #174687
    Mo

    Hi Tom,
    Disabling all but the GP plugin made no difference.

    Everything except the font family changes when adjustments are made.

    All typography elements should appear using the “Impact” font family and in bold (Just for testing).

    IE and Chrome display the page with the new font family correctly but not Firefox.

    Finally generated a debug.log for you.

    Made some changes in the Customizer to generate this.

    Most of it was comprised of duplicate entries so here it is condensed:

    [23-Feb-2016 15:17:54 UTC] PHP Notice: Undefined variable: generate_settings in /srv/www/vhosts/inthelink.com/httpdocs/wp-content/plugins/gp-premium/addons/generate-menu-plus/functions/generate-menu-plus.php on line 732

    [23-Feb-2016 15:17:58 UTC] PHP Notice: Use of undefined constant GENERATE_VERSION – assumed ‘GENERATE_VERSION’ in /srv/www/vhosts/inthelink.com/httpdocs/wp-content/plugins/gp-premium/addons/generate-typography/functions/customizer/google-font-dropdown-custom-control.php on line 182

    [23-Feb-2016 15:17:58 UTC] PHP Notice: Use of undefined constant GENERATE_VERSION – assumed ‘GENERATE_VERSION’ in /srv/www/vhosts/inthelink.com/httpdocs/wp-content/plugins/gp-premium/addons/generate-backgrounds/functions/controls.php on line 74

    These are the 3 errors being generated repeatedly in the log.

    Let me know if you need the entire log.

    Thanks.

    #174720
    Tom
    Lead Developer
    Lead Developer

    Those notices are telling me that the GeneratePress theme isn’t activated.

    If you go to “Appearance > Themes”, what’s the activated theme?

    #174785
    Mo

    I had changed to Twenty-Sixteen as WordPress had suggested and must have sent you the log from when that occurred.

    GP has been re-activated and will send you an updated log.

    #174796
    Mo

    It’s not my day today… the debugger has now stopped reporting.

    Now it appears the debugger needs debugging.

    Don’t know why this has occurred either.

    #174811
    Mo

    Here’s what I pasted in the wp-config this morning:

    // Enable WP_DEBUG mode
    define( ‘WP_DEBUG’, true );

    // Enable Debug logging to the /wp-content/debug.log file
    define( ‘WP_DEBUG_LOG’, true );

    // Disable display of errors and warnings
    define( ‘WP_DEBUG_DISPLAY’, true );

    Rechecked it and the code is still there.

    Since enabling the GP plugin there hasn’t been any error reporting activity that I’m aware of.

    Changing the typography settings is not producing any screen errors or debug logs.

    Perhaps I’ll have to use Chrome or IE to see the true styling of the site.

    Firefox must be broken in some way.

    #174858
    Tom
    Lead Developer
    Lead Developer

    There shouldn’t be any errors or warnings when GP is active, so that’s good.

    Any chance you can send me temporary admin login details to support@generatepress.com? Wouldn’t mind checking it out myself.

    Let me know 🙂

    #174903
    Mo

    Something that just occurred to me this morning while thinking about what’s different from the last build where everything worked perfectly and this current build where there’s issues.
    The answer… Cloudflare.

    The previous build’s web host couldn’t easily implement Cloudflare into it’s system so it was not used.

    On this current build, Oone of their apps was causing a “mixed active content warning” for the HTTPS.
    Only in Firefox.
    IE and Chrome were fine.
    Disabling the app resolved the issue.

    One of their other apps could be the issue here as well.
    This will be checked out ASAP and I’ll let you know.

    If that fails to resolve it, then I’ll give you a login account.

    Thanks Tom,
    Mo

    #174919
    Mo

    Hi Tom,
    Cloudflare has nothing to do with the typography font family problem.
    After disabling everything, it still persisted.

    Everything still pointed to Firefox as the problem as 4 other sites using GP experience the same issue.

    So I went to mozilla.org and performed a complete refresh of the Firefox browser.

    As the latest version was installed, I used the Firefox tuneup feature.

    This cleared everything that was installed on the browser, including add-ons, history, bookmarks, cache, etc.

    Went back and logged into the current GP build and voila! the typography font family changes were visible.

    Double checked by changing all font family settings which all worked flawlessly.

    Obviously there was something installed in Firefox that disagreed with GP.

    Kind of weird because restarting Firefox in safe mode made no difference.

    Now it’s a matter of re-installing the Firefox backup I made before the tune up and enable everything one by one.

    If and when I find the culprit, I’ll let you know just for future reference to other GP users.

    Thanks a lot for your time!
    Mo

    #174928
    Mo

    Hi Tom,
    Found the culprit and it wasn’t what I expected.
    It seemed that it would be more likely to be a Firefox add-on, them ore extension.

    Turned out to be a simple setting under the Firefox “Content” option.

    After installing Windows 10 in January, I had chosen to disable “Allow pages to choose their own fonts, instead of my selections above” setting in Firefox and, of course, completely forgot about the setting.

    Unchecking it locked all fonts to what was chosen as the default for ALL webpages.
    That being Arial.

    Checking it allowed the typography settings from GP displayed to display properly.

    Pretty much shot myself in the foot…

    So nothing serious, only slightly embarrassing.

    Something for future reference if anyone else ever has this “problem”.

    Thanks for the support.

    Awesome as usual!

    Regards,
    Mo

    #174973
    Tom
    Lead Developer
    Lead Developer

    Ah! I’m glad you found the issue! Glad it wasn’t GP 🙂

    #289250
    Dimitra

    Thank you so much Mo for applying the solution. It helps me a lot with the current typography problem with Firefox.
    Wish you lots of success!
    Dimitra

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.