[Resolved] Translation not loaded in Customizer

Home Forums Support Translation not loaded in Customizer

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #970190
    Robin

    I am finally the PTE for the translation of the GP theme! Approved all translations, and the translation (Dutch) has been added to the site with the WP updater.

    Now when I go to the Customizer, all is still in English. The translations are not loaded.

    Downloaded the .po file from my site using FTP, and that one is all in Dutch, so the translation is there.

    I checked some of my other sites, and they all have the same issue. Cleared site cache and browser cache, no change.

    Any idea what can be the problem?

    #970573
    Tom
    Lead Developer
    Lead Developer

    Hey Robin,

    Thank you so much! Really appreciate it 🙂

    Is there an “Update Translations” button in “Dashboard > Updates”? If so, can you try clicking it?

    #970907
    Robin

    Hi Tom,

    Thanks for replying. Gladly done!

    Nope, all updates have been done.

    Like I said, the translation is present in /wp-content/languages/themes and is called generatepress-nl_NL.po. The file is the correct version, it’s just not being loaded when running the Customizer.

    On a test site I have, running GP, I turned off GPP (version 1.8.3) and the translations were showing. Turning GPP on again, and all is in English. So seems to be an issue in GPP.

    BTW: I translated the theme into Dutch, but prefer the US version of the language file. Need to think of a solution for that 😉

    Hopefully you can find what’s wrong.

    Regards,

    Robin

    #971214
    Tom
    Lead Developer
    Lead Developer

    Hey Robin,

    Strange, GP Premium shouldn’t interfere with translated words that are based in the theme.

    However, GP Premium does overwrite some of the Customizer options that exist in the free theme, so it’s possible that you need to translate those specific words in GP Premium as well: https://translate.generatepress.com/

    #971338
    Robin

    GPP has been translated fully by me as well. The GPP screen is in Dutch, but the Customizer isn’t.

    #971644
    Tom
    Lead Developer
    Lead Developer

    None of the Customizer is at all? Or only some portions? If so, which portions?

    #972247
    Robin

    Almost all is in English, but a few translations slip through.

    I took some screenshots from a demo side I have:

    Main menu with GPP plugin on:

    Main menu with GPP plugin off:

    Mixed languages:

    #972319
    Tom
    Lead Developer
    Lead Developer

    So it looks like your GP Premium translations aren’t coming through.

    Just to confirm, you’ve added the complete gp-premium-nl_NL.po file to the wp-content/languages/plugins folder?

    #972338
    Robin

    Just checked in the /wp-content/plugins/gp-premium/langs folder (not /wp-content/languages/plugins) and there were some language files in there, but not the gp-premium-nl_NL.po and gp-premium-nl_NL.mo files.

    I downloaded the .po and .mo from https://translate.generatepress.com/, placed them in /wp-content/plugins/gp-premium/langs, and now all is okay.

    Thanks for that, but this does pose the following questions:

    1. why were the Dutch translations not in the folder, while some others (like Portuguese and Russian) were?
    2. why was a small part translated, but the rest not?

    I guess it is not normal procedure for admins to have to download their languages, is it?

    #972580
    Tom
    Lead Developer
    Lead Developer

    We no longer want to store all of the available languages in the GP Premium plugin, as the size of the plugin will get pretty big.

    Instead, it’s best to load those translations into the wp-content/languages/plugins folder, which is where WordPress stores languages now.

    We’re working on a one-click method to download those files and add them to that folder, so you don’t have to do it manually.

    #972899
    Robin

    I understand, that will be too much.

    That would be very nice to be able to select the language you want to use from the GPP settings and have it installed automatically.

    Thanks for all the replies!

    #973191
    Tom
    Lead Developer
    Lead Developer

    No problem! Let me know if uploading the files to the wp-content folder doesn’t work 🙂

    #973242
    Robin

    Works for me, but I’d rather not do this manually on all my client sites.

    #974072
    Ed

    Hi,

    After upgrading my WP site to GP Premium, I noticed that the more tag was reverted to Read more instead of the Dutch equivalent. So, if I don’t want to wait until the one-click method becomes available, how can I get hold of the two Premium language files, and fix the problem the same way Robin did?

    Ed van der Meulen,
    The Netherlands

    #974422
    Tom
    Lead Developer
    Lead Developer

    You should just be able to change it in Customize > Layout > Blog.

    Let me know 🙂

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.