[Support request] TCB_MenuWalker error – just appeared

Home Forums Support TCB_MenuWalker error – just appeared

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1061404
    Stephen

    Hi there

    I am using GP with Thrive Architect as my page builder, was working fine even up till yesterday

    Now getting this error, which from doing some research might be showing some issue between theme and page builder.

    Warning: Declaration of TCB_Menu_Walker::walk($elements, $max_depth) should be compatible with Walker::walk($elements, $max_depth, …$args) in /home/reed1968/public_html/incomeprotectionplus.co.uk/wp-content/plugins/thrive-visual-editor/inc/classes/class-tcb-menu-walker.php on line 0

    I think that there maybe something I can add to the theme to removed this issue,any help much appreciated

    It’s not happening on any of my other sites, which use the same setup.

    Many thanks

    #1061668
    David
    Staff
    Customer Support

    Hi there,

    Has the Site updated to WP 5.3? As this is a known issue see here:

    https://make.wordpress.org/core/2019/10/09/wp-5-3-introducing-the-spread-operator/

    As the error is related to the Thrive plugin they will need to ‘patch’ there plugin to overcome this.

    #1062140
    Stephen

    Thanks David

    In fact, I’ve just changed all the pages to a different builder.

    Yes, it did update, seems not to have done on my other sites yet. I’ll hold off from that update until I get this sorted

    Cheers for the heads up

    #1062161
    David
    Staff
    Customer Support
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.