[Resolved] Styling Issue

Home Forums Support Styling Issue

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #1034504
    Matt Stern

    Hi Guys,

    Wondering if you can help me troubleshoot this…

    All product pages, such as this one: https://naturespiritherbs.com/product/kelp-fronds/

    load with extra padding on the right that pushes the content over.

    The problem is resolved when I switch themes (tried both stock 2019 theme and Astra), so it appears to be Generate related?

    I also deleted all my custom css just to make sure it wasn’t causing the problem, and that didn’t help.

    I’ve set you up as an admin in case you want to poke around. Thank you for any help!

    Matt

    #1034513
    Leo
    Staff
    Customer Support

    Hi there,

    I can see the correct layout for a second when the page is first loaded:
    https://www.screencast.com/t/3FQmCRzcDGk

    Have you tried disabling all plugins except GP Premium and Elementor to test?

    The only thing GP is doing for that page is setting the container to be full width:
    https://www.screencast.com/t/he1A83Cx4tva

    And since all other sections (like Descriptions) are working correctly, it really can’t be a GP issue.

    If disabling plugins don’t help, I would recommend checking with Elementor’s support.

    Let me know 🙂

    #1034705
    Matt Stern

    I disabled all plugins except GP premium, Elementor, Elementor Pro and Woocommerce, same issue:
    https://naturespirit.dev.onpressidium.com/product/kelp-fronds/

    Elementors response was to try a different theme, and since the problem resolved with a different them, they’re saying it must be your theme!

    Any other ideas? Thanks!

    Matt

    #1034739
    Leo
    Staff
    Customer Support

    Elementor’s support is always blaming the theme 😉

    As my screenshot shows, it was loading correctly for a second before something else kicked in and GP certainly doesn’t do that.

    If it’s indeed a GP issue, then every section would align to the left.

    Any chance you can ask them to identify the issue instead of just saying switching a theme?

    I really don’t see how this could be a GP issue.

    #1034768
    Matt Stern

    Yes, I will press them. Thanks, Leo.

    #1035327
    Leo
    Staff
    Customer Support

    Let me know how it goes 🙂

    #1035593
    Matt Stern

    I’m not sure if this is a relevant clue, but the site is loading fine on Safari…

    #1035608
    Leo
    Staff
    Customer Support

    Was Elementor able to identify the issue?

    Might be good to mention this to them as well.

    #1036507
    Matt Stern

    Elementor gave me this code:

    .elementor-column-gap-wider {
    
    width: 100%;
    }

    Though I’d prefer to get to the root of the problem, this does fix the brokenness. Better than nothing!

    Thanks for the help.

    Matt

    #1037331
    Leo
    Staff
    Customer Support

    Glad they were able to sort it for you.

    Please try to keep in mind that we are confident enough to say it’s rarely a theme issue when it comes to Elementor conflicts.

    #1037341
    Doug

    I’m having the exact same issue and got the exact same response from Elementor.

    #1037344
    Doug

    Well…not exactly…it’s happening to my blog archive.

    #1037346
    Doug

    Well…not exactly…it’s happening to the blog archive.
    Using a default theme I don’t have the issue.

    #1037351
    Doug

    Except the css part, the didn’t send me a work around… but as Matt pointed out… it would be nice to get to the root of the issue.

    Also, I just noticed the screen recording they sent me. I shows them switching the theme to Astra and not having the issue and I used 2019 and no issues.

    https://solids-n-stripes.com/blog/

    #1037375
    David
    Staff
    Customer Support

    Hi there,

    go to Customizer > Layout > Blog and disable the Columns.
    If you’re building the blog with Elementor then you can just disable the GP Blog Module.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.