[Resolved] Sticky navigation causes site to jump

Home Forums Support Sticky navigation causes site to jump

  • This topic has 7 replies, 3 voices, and was last updated 1 year ago by Tom.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1141857
    Marius

    Hi,

    I’ve noticed that the site body would briefly jump with certain settings for “Layout -> Primary Navigation” and “Layout -> Sticky navigation”. The problem goes away once I disable the “navigation search” option in “Layout -> Primary Navigation” dialog.

    I’m on the latest versions. The test website (for you folks from GP staff) is basically a fresh WP installation where I installed the GP Theme + Premium, imported the site from the site-library, and changed settings only in Layout -> Container/Header/Primary Navigation/Sticky Navigation. Let me know if you want admin access, this is a pure test-site.

    Thanks!
    Marius

    #1141911
    Leo
    Staff
    Customer Support

    Hi there,

    Just checked the link and not noticing anything obvious.

    Is there a specific page where I can see this issue?

    Let me know πŸ™‚

    #1141917
    Marius

    Any page that has sufficient material to allow for vertical scrolling. The “About me” page for instance. Use Firefox ;).

    #1141958
    Leo
    Staff
    Customer Support
    #1142231
    Marius

    Hi Leo. On the particular site I sent you, the fix works. Thank you. However, I have another site (just take the original URL and let it end with “wordpress/”, instead of “wordpress-test”). There, even when applying the fix, the site is still jumpy during vertical scrolling, even in Chrome! The jumps would only stop if forced the menu items to be placed below the logo, e.g. by increasing “Menu Item Height” setting (from 20 to something larger), or enforcing a “Navigation drop point”, which is not what I want.

    Best regards!
    Marius

    #1142910
    Tom
    Lead Developer
    Lead Developer

    Can you try adding this, instead?:

    #sticky-placeholder .navigation-branding {
        display: none;
    }

    Let me know πŸ™‚

    #1142925
    Marius

    That did the trick, thanks!

    #1142932
    Tom
    Lead Developer
    Lead Developer
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.