[Resolved] Sticky menu causes the content to jump or jerk when scrolling down

Home Forums Support [Resolved] Sticky menu causes the content to jump or jerk when scrolling down

Home Forums Support Sticky menu causes the content to jump or jerk when scrolling down

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #521841

    So whenever you enable the sticky menu (in some cases not all) it causes the body/content to jump or jerk. I made a video to explain better and show you, but also provided various links of different sites we’ve done that’s doing this as well.

    All of the below links are https btw:

    Here’s a short video showing you what I’m talking about… https://www.dropbox.com/s/ps5sthelisskv6a/GP-Sticky-Menu-Issue.wmv?dl=0

    benanderson365.com/?access=site (Temp address to get access to the front end while it’s “coming soon”)

    It does it on a lot of our sites but here are a few more to look at for examples…
    abccabdurham.com/reservations (does it on all pages but this one is easiest to see it on)
    nevadaurbanindians.org/board-of-directors This page does it but not the home page for some reason.

    Different sites are using different versions but all are using premium for certain.

    Thanks in advance,

    Customer Support

    Hi John,

    Does that happen on a setup where only GP is activated?

    I can’t get it happen on any of my installs or our demo page: http://demo.generatepress.com/

    Let me know.


    I think it’s a combination of sticky and some other things, not really sure what. But it’s only GP, I don’t do ANY other themes. If someone wants a custom theme, I build it in GP because GP is amazing and insanely flexible. 🙂

    I can disable all of my other plugins and test, so I will get back to you on that. But other people were talking about it too in the other post, just wanted to mention that.



    I’ve finally gotten time to get back to this issue, which still remains to this day. I have over 300 installs of GP and almost all of them are doing it. I finally determined what is probably causing it. I see that it stops when disabling the search button in the menu.Not that this is a solution, just a patch for anyone encountering this problem.

    Customer Support

    Thanks John – i replied to the other topic


    Hi Jonh and David.

    First, I am sorry for my poor English level.

    I have fix for this issue. It is to easy…..

    Appearance >> Desing >> Fixed navigation >> Transition >> Select option None

    I am sorry so much if the steps are not exactly (for my low level of English) but the solution is there.

    Kind Regards form SPAIN



    That didn’t work for me. Here’s one of many examples: https://carterlawok.com/?access=site (this is a temporary build so it needs the ?access=site at the end to see it while we build the site)

    It also happens on regular pages https://carterlawok.com/our-firm/our-team/jeremy-z-carter/?access=site

    I would note though, that it does definitely have something to do with the sticky navigation because when I check the box to “hide when scrolling down” it still does it. And when I disable it altogether, it doesn’t do it at all.

    And I also want to remind everyone that this is only happening in FireFox, not Chrome.


    Hi John. Ok I understand.

    If I found a solution for the issue in FireFox i will write here.

    Good Luck.

    Kind Regards, Alberto.


    To all that need it, I found the solution for this issue (which Tom put in another post), here it is…

    #sticky-placeholder {margin-top: 0;}
    #sticky-placeholder .navigation-branding {display: none;}
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.