[Resolved] Spacing Between Paragraphs

Home Forums Support Spacing Between Paragraphs

  • This topic has 8 replies, 3 voices, and was last updated 4 months ago by Leo.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1293558
    Earl

    Hello,

    Is there custom CSS or an option to increase the size of spacing between paragraphs?

    I did find the option in Customize -> Typography -> Line Height – but this did not change the spacing I’m referring to. If you look at this page – you can see the spacing between each paragraph is pretty large. How can I target that spacing?

    Part of the issue might be related to that I am using GenerateBlocks for text – so maybe the solution needs to go through that rather than the customizer? I love GenerateBlocks so it’d be awesome if I can fix the paragraph spacing and keep using those.

    I know I could probably create a separate block for every single paragraph and adjust the margin between every block – but it seems somewhat messy to create separate blocks for 200 paragraphs with margin adjustments – rather than just one paragraph block with appropriate margins between the paragraphs within that block.

    I also looked for options in GenerateBlocks typography – and saw a few options – but nothing that targeted paragraph margins/spacing.

    #1293632
    David
    Staff
    Customer Support

    Hi there,

    that would be controlled by the Customizer > Typography > Body –> Bottom Margin

    The only reason it wouldn’t apply is if you have edited the bottom margin on the actual block.

    #1293652
    Earl

    I don’t see any “Bottom Margin” option – only Font size, Line height, and Paragraph margin. See screenshot here.

    #1293730
    David
    Staff
    Customer Support

    My bad – i meant Paragraph Margin

    #1293971
    Earl

    This actually doesn’t fix the problem.

    For testing purposes, I set Paragraph Margin to 5 em. You can see on the home page hero section – it does make it much larger so I did correctly set the Paragraph Margin to 5.

    However, the problem I’m trying to fix is to adjust the spacing between paragraphs in the Generateblocks heading block. If you look on the about page, you can see that the paragraph spacing in the heading blocks themselves did not change when I adjusted Paragraph Margin.

    I could probably create separate Generateblocks for every paragraph – but it’d be pretty messy solution to create hundreds of blocks in a blog and have the margins adjusted individually on each text block.

    #1294071
    Leo
    Staff
    Customer Support

    The customizer setting is getting overwritten by the headline block setting as it should:
    https://www.screencast.com/t/r5YnxQWs

    I wouldn’t recommend using the headline block to insert paragraph as it should be used for headings generally – it would be best to just use the standard paragraph block from the core.

    #1295276
    Earl

    I’m still running into problems with this solution – I am able to edit the spacing between paragraphs but it has other side effects.

    Take a look at this sample blog.

    I want to use the Generateblocks Container to create a “hero” type background image across to the top of the blog. To do this, it seems I have to select “Set Full Width Content” and there is no other way to create the hero effect with the block editor (let me know if this is wrong).

    Once I click the option to “Set Full Width Content” – the full width then applies to all blocks on the entire page. This creates the problem where the paragraphs in the Body are now full-width – but they should be contained. To correct this problem, I put the Gutenberg standard paragraphs into a Generateblocks Container. This allows me to get the paragraphs in a proper contain.

    The problem created then is that the Paragraph Margin option doesn’t seem to apply to Gutenberg paragraph block within the Generateblocks Container.

    So – here’s the thing I need help with: how do I use the block editor to create a full width picture, but then also be able to create paragraphs that aren’t full width AND have appropriate paragraph spacing between them. In other words, the Paragraph Margin function in the customizer doesn’t appear to work on a Gutenberg Paragraph block within Generateblocks Container.

    #1295545
    Earl

    I was able to resolve this problem – without too much difficulty. I’ll describe my solution here for future usse:

    You can achieve a “full width” image using the Gutenberg Cover Block – just select the “Full Width” alignment. This did not then make changes to any other blocks on the pages – it simply went full width.

    As a bonus, I was able to achieve the full width with the Gutenberg Cover block – EVEN in a Generateblock. This could prove very useful for quickly generating unique or advanced hero sections.

    #1295615
    Leo
    Staff
    Customer Support

    Glad you’ve figured out 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.