[Resolved] site_url and home are set to https in database, but in WP backend still is http

Home Forums Support [Resolved] site_url and home are set to https in database, but in WP backend still is http

Home Forums Support site_url and home are set to https in database, but in WP backend still is http

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #597403
    Mirko

    Hello Leo,

    I have a little problem with WP which is really driving me insane. My researches in Google, Stackexchange and many more didn´t help. It doesn´t concern your theme directly, but maybe you have heard of an similar problem and could help me to find sleep again 🙂

    Ok, here we go:

    I migrated my web from http to https by changing the database options, using “Better search and replace” and setting the htaccess redirect. All resources were deliverd via https and the Firefox showed a green lock. Everything seemed to work fine – at first sight.

    But when now uploading a new image it will be delivered via http?!

    I immediatle checked my database but in options/home and options/siteurl the entry is https. In wp-config I also use define(‘FORCE_SSL_ADMIN’, true);. And now the curious thing: When checking the WordPress address (URL) under “Settings/General” there is a http-entry which cannot be edited.

    entry of home is http and cannot be edited

    I already tried to bugfix it by disabling all plugins and installing the twentyseven theme, but the problem still exists.

    The db says https but the backend says http… Ever heard of a similar problem?

    Thanks a lot in advance and have a nice day!

    Greetings from Germany

    Mirko

    GeneratePress 2.1.2
    GP Premium 1.6.2
    #597471
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Usually those options are greyed out when you’ve set the URL inside the wp-config.php file.

    Perhaps check that file for the http URL.

    Let me know 🙂

    #597479
    Mirko

    Hi Tom,

    thanks for the immediate answer. Yeah, I already checked the wp-config.php and all other files in the WP folder, but there´s nothing hard coded regarding the http in there.

    I really “stripped the whole WP to the bone”, disabled all plugins, changed the theme, but it is still http…

    #597481
    Tom
    Lead Developer
    Lead Developer

    That’s very strange. The only way I know of that will make that area non-editable would be to have this in the wp-config.php file: https://codex.wordpress.org/Changing_The_Site_URL#Edit_wp-config.php

    Here’s the code inside WordPress: https://github.com/WordPress/WordPress/blob/b13e73d05c98be8604c4eb11b83cf299da7ce18f/wp-admin/options-general.php#L80-L82

    The only way that option gets disabled is if WP_HOME is defined somewhere.

    #597484
    Mirko

    Ok, I will try to find where wp_home is defined… Thanks for your help! I really enjoy your perfect support!

    #597495
    Jacky

    I know I had that problem before and my setup is multisite. I have to changed it in the db and restarted the web server.

    Jacky

    #597814
    Tom
    Lead Developer
    Lead Developer

    No problem! Let me know if you find it or not 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.