Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Since update to 1.2.1: no mini icons?

Home Forums Support Since update to 1.2.1: no mini icons?

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #39385
    Jack Sankey

    Hello,

    I love this template. However, since updating today (via the “update” button provided by my wordpress admin page), I now do not seem to have any of the little built-in icons for things like “Categories” or “Tags”. Just a little square:

    http://www.sankeylab.ca/posts/category/news

    Is there an easy solution?

    Thanks!
    Jack

    #39399
    Tom
    Lead Developer
    Lead Developer

    Very weird – countless other websites that have been updated are showing those icons just fine, including the preview on WordPress.org: http://wordpress.org/themes/generatepress

    Do you have any custom CSS or plugins dealing with FontAwesome?

    Maybe a caching plugin? Minifying anything?

    #39525
    Jack Sankey

    No, not sure what’s causing it. I’ve since wiped all history, and just now tried disabling all plugins / wiping history / private session.

    I’m reasonable at coding if you tell me where to look. Also note my wp-admin is at a different address than my website (so I can log in over https)

    #39613
    Tom
    Lead Developer
    Lead Developer

    Hmm, it may have something to do with how you’ve set up your admin/https.

    Using Firebug, I get this error on your site (starred out sensitive info):

    Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://box***.bluehost.com/****/****/wp-content/themes/generatepress/fonts/fontawesome-webfont.woff?v=4.2.0. This can be fixed by moving the resource to the same domain or enabling CORS.
    http://box**.bluehost.com/***/****/wp-content/themes/generatepress/fonts/fontawesome-webfont.woff?v=4.2.0
    Line 0

    I’m not 100% sure how you’ve set stuff up, but perhaps this helps you?

    Let me know 🙂

    #39797
    Jack Sankey

    I dug around the interwebs for this error and found something about enabling “Cross-Origin Resource Sharing”. I ended up adding the following line to my .htaccess file:

    Header set Access-Control-Allow-Origin http://www.sankeylab.ca

    which made it work. Weird that this wasn’t necessary prior to the update, but no complaints.

    Now if I can only figure out how to get the little “edit this post” link to appear when I’m logged in to wordpress… Having the different domains for the wordpress login and actual website causes so much trouble.

    Thanks Tom! Your obvious responsiveness (and awesome theme) was what originally encouraged me to pull the trigger on the “pro” version. No regrets!!

    #39801
    Tom
    Lead Developer
    Lead Developer

    Hi Jack,

    It probably happened after the update because I was originally pulling the FontAwesome file from their CDN, but WP.org frowns upon that so I packaged it within the theme for this version – didn’t anticipate it causing issues, sorry about that!

    If you got the other icons to appear, the “Edit” link and icon should be there – let me know if you can’t figure it out.

    Thanks! I really appreciate the support 🙂

    #39808
    Jack Sankey

    No worries. I’m not expecting a lot of traffic. 🙂

    Regarding the “edit this post” link, I have a suspicion this is a wordpress / bluehost problem. I basically added this after the content (with your GP Hooks plugin):

    [<?php edit_post_link(‘edit this post’, ‘<p>’, ‘</p>’); ?>]

    You can see the little brackets with nothing inside on each post, so I know it’s at least trying to do what I want it to do. Nothing appears, though, and I’m logged into wordpress (via the other secure address / domain) in another tab.

    Anyway, if you know the trick here, let me know, but otherwise I’m going to be poking bluehost about it.

    Thanks again!
    Jack

    #39813
    Tom
    Lead Developer
    Lead Developer

    There should already be an edit link below each page/post when you’re logged in by default – shouldn’t be any need to add one.

    #165288
    avraham

    Hi,

    I am also trying to fix the font awesome issue where the icons don’t show up, but I don’t understand how to fix it. Are there step by step instructions somewhere I can access?

    Thanks so much,
    Dina

    #165344
    Tom
    Lead Developer
    Lead Developer

    First step is to make sure your URLs in “Settings > General” are both identical.

    #165377
    avraham

    Hi Tom,

    Thanks. Yes, both say http://thejwws.com.

    All the best,
    Dina

    #165468
    Tom
    Lead Developer
    Lead Developer

    I’m seeing your icons: http://thejwws.com/blog/

    Where aren’t they showing up?

    #165547
    avraham

    Hi Tom,

    I hadn’t put any icons on the blog page.

    I played around and I think either it is because the icons were in a column, or because I put heading tags around them. Could that have been it possibly?

    Because I put the icons without the columns and without the h tags and I see them now.

    On these pages so far:
    http://thejwws.com/
    http://thejwws.com/jwws-2016-child-care-information/
    http://thejwws.com/food-and-kashrus-information/

    And so far they are staying. Great news, and I hope it lasts.

    Thanks, all the best,
    Dina

    #165601
    Tom
    Lead Developer
    Lead Developer

    Where you place them shouldn’t matter really – just make sure you add the correct classes.

    For example:

    <i class="fa fa-bars"></i>

    Everything looks great on your site to me 🙂

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.