[Support request] Setting image attachment link to "none"

Home Forums Support Setting image attachment link to "none"

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #996526
    Anton

    Hi there,

    I moved theme to GP last week and noticed today that some images on my site are linking to an image file, where on my old theme they were linking back to the post. I’ve tried setting ‘none’ in wp-admin/options.php, and this worked with my old theme but doesn’t seem to work with GP.

    I’ve also set images to redirect to the post in All in One SEO, but going through the site, I see that some images are opening as links, others redirect to the post and others aren’t clickable at all!

    This seems like it’s a WP-setting rather than a theme-related issue, but not sure. Any ideas on how to set all existing images to ‘none’? All new images are fine as the default is now set to ‘none’.

    Thanks

    #996646
    Leo
    Staff
    Customer Support

    Hi there,

    I believe the Link To setting is what you are looking for:
    https://codex.wordpress.org/Inserting_Media_into_Posts_and_Pages#Step_4_.E2.80.93_Attachment_Details

    Let me know if this helps 🙂

    #996690
    Anton

    Hi Leo,

    Yep, I know about the setting and I have it set to ‘None’ for all new images I add 🙂

    What I mean is I am looking for a way to set all images on the site to ‘None’, without having to do so individually? With my old theme the wp-options setting seemed to do this, but with the move to GP it looks to have reset, where some images link to the file and others don’t.

    #996691
    Leo
    Staff
    Customer Support

    GP shouldn’t interfere with the WP options settings.

    Does it work as expected if you switch to a default WP twenty series themes?

    #996695
    Anton

    Yeah that’s why it seems strange. I haven’t tried it with a default theme. With the current site that’d involve a bit of work – I’d need to move to a test server, etc.

    On another site I have with GP, the images aren’t even clickable.

    #996714
    Leo
    Staff
    Customer Support

    I believe the image_default_link_type setting doesn’t actually change the existing images, only new images.

    Definitely worth switching to a default WP theme to test quickly then switch it back 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.