🎉 Happy 4th of July! Get 15% off GP Premium with the discount code: 4THOFJULY2020

[Resolved] Setting Default Media Library Location

Home Forums Support Setting Default Media Library Location

  • This topic has 3 replies, 2 voices, and was last updated 5 months ago by David.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1150017
    Michael

    Hi all,

    I know this is not a question specifically linked to GeneratePress, but my web search hasn’t yielded anything that I’m 100% sure to try, and I don’t want to break the theme.

    Basically I’d like to set the default media library location to be:

    /wp-content/uploads/images

    Instead of what it is defaulting to:

    /wp-content/uploads/2020/01/

    There are already images in the default location, so I was going to just cut and paste them in FileZilla to a new location, but after reading some posts apparently this can break the WordPress database. Apparently it is possible to edit the config.php directly, but I wanted to ask if there is a custom snippet I could use so as I don’t potentially cause issues?

    Many thanks for your help.

    Michael.

    #1150179
    David
    Staff
    Customer Support

    Hi there,

    simple part is disabling: Organize my uploads into month- and year-based folders in Settings > Media for all future uploads.

    Then i am not sure of the best route – some data in the WP database is serialized so simple search and replace may fix broken URLs. And it won’t pick up on external files requesting the images.

    How many images are there ? If its an early build and you only have a few may be simpler to rename and reupload the originals and swap them out across the site.

    #1150513
    Michael

    Thanks David. I’ve made those changes to settings. I previously attempted to import images from a Weebly export. I’ve deleted them and added again, so hopefully that will do the trick.

    #1150862
    David
    Staff
    Customer Support
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.