Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Set maximum post length

Home Forums Support Set maximum post length

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #34291
    Ben Hourahine

    Hi Tom,

    Is this possible?

    I would like to do it to retain images, videos and post content, but limit the length of text featured on the front page(s). I would like to do this without using an excerpt type setting as I seem to lose the media / rich content.

    Thanks again (last question from me for now!)

    Ben

    BIG Generatepress fan 🙂

    #34337
    Tom
    Lead Developer
    Lead Developer

    Hi Ben,

    You can use the “Read More” tag to set a specific point in which to cut off your blog posts. This will retain your images and other HTML, and cut the excerpt off exactly where you want.

    http://en.support.wordpress.com/splitting-content/more-tag/

    Let me know if that helps or not 🙂

    #34611
    Liz Steyer

    I’m going to jump in on this thread because I had a similar question. However, I attempted to use the “Read More” tag as suggested, and it cuts my post off in the right place but not does not show a link in the excerpt to click for more.

    If I rely on the excerpt type setting, I can’t control each individual post, but at least I get a “Keep reading…” link at the end of the excerpt. But, if I try to use the “Read More” tag, it cuts off right where I want it but without that link so from the excerpt page it just looks like I have an entry with a couple sentences and no way to get the rest of the content.

    #34612
    Tom
    Lead Developer
    Lead Developer

    Hmm that’s odd – I just gave it a try myself and “Read more…” shows up if I use the Read More tag.

    The only time it doesn’t show up is if I use the custom excerpt metabox – and I’m working on that.

    Are you using the most up to date version of the theme?

    Let me know 🙂

    #34613
    Liz Steyer

    Thanks for the quick reply.

    Everything is up to date, and I’ve tried everything I can think of. I thought it might be because I’d imported a lot of posts from another blog, but even creating a new post and trying the “Read More” tag results in no click through text.

    #34659
    Tom
    Lead Developer
    Lead Developer

    Do you have any other plugins installed?

    Can you try deactivating your plugins and see if the link appears?

    If so, can you activate each plugin until it disappears again, so we can see which plugin is causing it?

    Let me know what you find out 🙂

    #35861
    Liz Steyer

    Hi, Tom.

    Sorry for not responding quicker. I disabled all my plugins just now and the link is still not showing up. I don’t have much experience with WordPress so I don’t know if I’m just overlooking something. I appreciate any help you can provide. Thanks!

    #36315
    Tom
    Lead Developer
    Lead Developer

    Can you possibly email me a link to your website to support@generatepress.com?

    Should help if I can see what’s going on 🙂

    Thanks!

    #36897
    Tom
    Lead Developer
    Lead Developer

    Ok, I figured it this – and it seems to be more a WordPress limitation than a GeneratePress issue. That being said, I’ll look into a solution.

    The issue is when you choose to display the excerpt, instead of the full post.

    When your option to set to display the excerpt, the WordPress function the_excerpt() is used, and won’t listen to the Read More tag.

    The Read More tag is designed only for the_content(), which is the function used when displaying the full post.

    So, for now, if you’re wanting to use the Read More tag, you’ll need to do so on all posts, and set it so the full post is displaying through the Blog settings.

    Let me know if that makes sense or not 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.