[Resolved] Set Front Page

Home Forums Support Set Front Page

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #116935
    Mark Hamilton

    First let me say, awesome job on the theme and plugins! It has made my life a little easier.

    I have a question, assuming the page I want my posts to appear on is called “Blog Page”:

    Under “Customize”, “Set Front Page”, I can only get posts to appear if I select “A Static Page” then “Front Page:Blog Page” and “Posts Page:Blog Page”. Why don’t posts appear when you select the other option “Your Latest Posts” under “Set Front Page”?

    Thank you so much!
    Mark

    #116937
    Tom
    Lead Developer
    Lead Developer

    Hi Mark,

    They absolutely should – that’s the default setting. When you set the front page to “Your latest posts” and go to your homepage set in “Settings > General”, what do you see?

    #116946
    Mark Hamilton

    Thank you for your quick reply. Okay so I have selected “Your latest Posts” and the posts have disappeared from the page. I don’t see a homepage under “Settings>General”. If i go to “Settings>Reading, I see “Front Page Displays as” and the “Latest Post Box” is checked.

    #116961
    Tom
    Lead Developer
    Lead Developer

    So when you go to your homepage (the URL set as your “WordPress Address” in “Settings > General”), no posts show up?

    #116982
    Mark Hamilton

    Thanks Tom. Okay so when I fire up another laptop and visit the site, yes it shows up on the front page after I have checked “Your latest Posts”. And all seems to be fine and remain the same after I visit other pages on the nav bar and return to the front page.

    However, when you use visit the site from within the wordpress dashboard, when the page first shows the front page, the posts are there. However if you visit other pages on the nav menu and go back to the front page the posts are gone. This may have confused the issue for me. But shouldn’t the posts remain when returning to the front page when visiting from the admin?

    #117033
    Tom
    Lead Developer
    Lead Developer

    Are you sure your menu item in the navigation is linking to the same URL you have set in “Settings > General”?

    #117097
    Mark Hamilton

    Thanks again Tom.

    I have built several static content pages, but not a blog with comments, so this is new territory for me. What I want to achieve is that the home page or “Blog Page” as I am calling it, shows my posts.

    To answer your question, yes, Settings>General the WordPress and site address are the same and set at the domain name for the site. I am not using any other domain names.

    When I “Set Static Page” with the “Front Page” at “Select”, “Posts Page” at “Blog Page”, Posts appear as desired. After visiting other pages on the site, and returning to the “Blog Page”, Posts again are visible.

    However, when the front page is set at “Your Latest Posts” and you visit the site, the Posts are there initially, but after you visit the other pages on the site and then return to the “Blog Page”, the posts are no longer there, just the title “Blog Page” and the comment boxes. Refreshing the url does not bring them back.

    Maybe this is normal? I don’t know, I am not a blogger (yet). But nevertheless, I am able to achieve what I want using the “Static Page” setting above. And I am working on two pages simultaneously, and they are both behaving the same way. They were going to be content pages, so maybe I did something in the settings? But I sure can’t find it if I did.

    #117164
    Tom
    Lead Developer
    Lead Developer

    If you set it so your front page shows your posts, then your “Blog Page” should no longer exist.

    The fact that you’re seeing the title “Blog Page” tells me that you’re trying to go back to the page which used to have your posts.

    When you set your front page to display your latest posts, those posts are no longer attached to any created page.

    What it sounds like is you have a menu item linking to your “Blog Page” page, but this page is no longer needed when your front page is set to display your posts.

    So, remove that menu item completely, and create a new “Custom Link” menu item which just links to your homepage.

    That should fix it.

    #117183
    Mark Hamilton

    Thank you Tom, it absolutely did fix it!

    All the Best,

    Mark

    #117184
    Tom
    Lead Developer
    Lead Developer

    Awesome! Glad I could help 🙂

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.