[Resolved] Semrush: links have no anchor text

Home Forums Support [Resolved] Semrush: links have no anchor text

Home Forums Support Semrush: links have no anchor text

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #2249701


    My question is not exactly related to Generatepress, but I couldn’t find a solution.
    Hopefully, you can help me a little further.

    After I do a site audit with Semrush I got the error message: “11 links have no anchor text” on the page in the private area.
    This URL, that generates the error message, is included in the private area.

    If I check the link on the container I don’t see anything wrong.
    My question is: what do I need to change to solve this?

    Thanks in advance.

    Best regards,

    Customer Support

    Hi there,

    does SEM Rush provide you a list of the problem links ?


    Hi David,
    Thanks that you have a look.
    I appreciate it.

    I included the rows in the private area.
    Is that the information you’re looking for?

    Regards Henk

    Customer Support

    I’m not sure unfortunately – don’t think it’s an error though if you don’t see anything wrong on the live page.

    Have you checked with Semrush’s support team to see if they can comment?


    I’ve asked Semrush if they could give me an explanation what the cause of the issue could be.
    They said it’s the following part in de page source: "...<span class="menu-bar-item search-item"><a href="#"><span class="gp-icon icon-search...". More specific the problem is: "..href="#"..".

    A while ago I tried to realize the search function where the user can press the magnifier class in the main navigation (see the website). When the user clicks on the magnifier, the page https://<sitename>/zoek should be displayed. But somehow I couldn’t get it working.

    I enabled navigation search in: Appearance > Customize > Layout > Primary Navigation.
    But I can’t specify that I would like to display the page https://<sitename>/zoek.

    Can you tell me how I can solve it?

    Thanks, Henk.

    Customer Support

    OK, so disable the navigation search in: Appearance > Customize > Layout > Primary Navigation.
    Then create a new Block Element – Hook:


    Set the Hook to: menu_bar_items

    In the content add a GB Button and give it a search icon, and add your search page link.

    Just to clarify the above issue where SEMRush is complaining about the href="#" – surely they have an option to ignore that? Its a valid use of the href – the W3 spec outlines its use for Return to Top of page, and we use it like a lot of other developers as a toggle.


    Hi David,

    Hi David,

    I created a new Element with type Hook and used the following code in the content area:

    <a class="button zoek" href="zoek">Zoeken</a>

    The text “Zoeken” is now a placeholder, if I click on it, it’s working and redirecting to the correct page.

    How can I replace the text with a magnifier icon? I already added a SVG image of a magnifier with the URL: https://sitename/wp-content/uploads/2022/06/magnifying-glass.svg

    Thanks for your help.

    Best regards, Henk

    Customer Support

    The easiest way is to use a block element.

    Since you are already using GenerateBlocks, you can add it like a normal button but in the block element.

    You can add the SVG icon to GB’s button, and there’s an option to remove text:

    Here’s a video that shows how to add an SVG icon with links to the topbar, you can have a look:


    Hi Ying, David,

    I solved it thanks to your both suggestions!

    Frist I created a temporarily block element to configure the button with only an icon. Then copy pasted the code en pasted it in the content area of a new Block Element – Hook and set the Hook to: menu_bar_items.

    Thanks for your help.

    Best regards Henk.

    Customer Support

    You are welcome!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.