[Resolved] Sections not appearing after using WP Export/Import

Home Forums Support [Resolved] Sections not appearing after using WP Export/Import

Home Forums Support Sections not appearing after using WP Export/Import

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #846752
    drew

    Hi guys, I have a very time sensitive issue here so thanks in advance if you can respond sooner than later. Specifically, I had a secondary install on a multisite that required a redesign but since the content on the other sites has been updated, doing a push from staging to live inside WPEngine wasn’t an option.

    Instead, I opted for an old-school export/import using the default WP function. While pages using sections show the content in text view (as expected) none of the actual sections appear. The thought of having to manually rebuild each of those (including settings) is a more than just a downer (it’s going to be an absolute day ruiner and damage cred with the client) so I’m hoping that I’m missing something here in the process.

    I’ve been through documentation and search the support board but am coming up empty. Thanks for your help.

    Drew

    GeneratePress 2.2.2
    GP Premium 1.7.8
    #847013
    Tom
    Lead Developer
    Lead Developer

    Hey Drew,

    Sections just use metaboxes, which do get exported and imported using the native WP tool. In fact, this is how some of our Site Library sites work.

    Did you try re-exporting/importing?

    #847540
    drew

    Thanks Tom, we’ve already manually rebuilt everything but that’s at least good to hear as confirmation. Hopefully, we won’t have to do this again but will try importing again.

    The only wrinkle there is this was a an “all content” export which means everything imported first time around would have to be manually deleted (time consuming when there’s lots of media involved).

    The WP importer is pretty sketchy in general, are there any recommendations on a specific process or type of export to use (i.e. pages only as opposed to all content)?

    Drew

    #847582
    Tom
    Lead Developer
    Lead Developer

    When you export it should give you an option to only export pages: https://www.screencast.com/t/3gNvgvrvvvU3

    The importer is definitely a little sketchy. I got to know it well when I was building the site library.

    #847699
    drew

    I bet you did, there are numerous quirks unique to multisite as well but I’ll try using the pages only option next time. Many thanks!

    #847800
    Tom
    Lead Developer
    Lead Developer
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.