[Support request] Search result page from widget breaks layout

Home Forums Support [Support request] Search result page from widget breaks layout

Home Forums Support Search result page from widget breaks layout

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #572527
    Jorge

    I’ve set up a search widget everything works just fine except when used on the homepage.

    The homepage settings are to be used without sidebars (the search results page has got one) and it’s set on FullWidth to use a page builder.
    The widget loads automatically (without needing to press enter on anything like that).

    The layout when the results appear breaks and the widget text is there but it’s hidden/doesn’t show up.

    I’m not sure where to look into. :/

    GeneratePress 2.1.1
    GP Premium 1.6.2
    #572759
    Leo
    Staff
    Customer Support

    Hi there,

    Sorry not quite understanding what the problem is.

    It does look like those elements are inserted using Visual Composer so perhaps check with their support?

    Let me know 🙂

    #575325
    Jorge

    Hi Leo!

    The issue is not with the elements of VC those are in place without any issue, and the results from the search page are loading as well. It’s the container the one that’s not working properly. The container is being displayed with a sidebar but it is not aligned and in some resolutions overlaps with the widgets area.

    Thanks!

    #575736
    Tom
    Lead Developer
    Lead Developer

    Your actual search results page doesn’t have a sidebar, so I’m not sure why it’s loading one.

    I assume you’re using a custom plugin for your search bar – perhaps ask them if it’s possible to add or remove a class from the body element once a search is entered?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.