[Resolved] Removing Page

Home Forums Support Removing Page

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #915005
    gedosan

    Hi Guys,

    I’ve realised google is displaying a page on my site that shouldn’t be there. The problem is it isn’t even a ‘real’ page on my site. I’ve tried submitting it to google’s removal tool, but they only remove pages that have had ‘no follow’ added to them. As its not a real page, I can’t go to Yoast to add ‘no follow’ to it.

    To me it looks like a system page that’s been automatically generated, like a category page but for ‘all pages’.

    Any ideas how I can remove it please?

    Cheers
    G

    #915435
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    /pages is the site? It looks like it’s set as your blog page. What page do you have set as the posts page in “Settings > Reading”?

    #915623
    gedosan

    Hey Tom,

    Just looked and actually I haven’t selected anything for the posts page. It could be that then. Weird thing is I have another site using GP and haven’t selected any page for that, but not getting the /pages/ page.

    I’ll give it a whirl.

    G

    #915638
    gedosan

    I created a new page and called it ‘/all-posts/’, then set it as the posts page. However, the /pages/ page is still there, and interestingly the title tag says ‘all-posts’. Now, I’m properly confused.

    Any ideas?

    #915699
    Tom
    Lead Developer
    Lead Developer

    Hmm, strange indeed. Any custom functions added to the site? Have you tried deactivating plugins to see if one of them is creating that permalink?

    #915715
    gedosan

    Functions (using Snippets plug in)

    Featured Image:

    add_shortcode(‘featured_img’, ‘fi_in_content’);

    function fi_in_content($atts) {
    global $post;
    return get_the_post_thumbnail($post->ID);
    }

    —-

    Remove link from date:

    add_filter( ‘generate_post_date_output’,’tu_remove_date_link’, 10, 2 );
    function tu_remove_date_link( $output, $time_string ) {
    printf( ‘<span class=”posted-on”>%s</span>’,
    $time_string
    );
    }

    —-

    Disable GP Schema:

    add_filter( ‘generate_schema_type’, ‘__return_false’ );

    —-

    none of those are the culprit right?

    G

    #915799
    Tom
    Lead Developer
    Lead Developer

    Nope, none of those would do it. Have you tested your plugins?

    You could always set up a 301 redirect on your server from that URL to the correct URL, but it is strange that the URL is working in the first place. Perhaps there’s something on your server causing it?

    #915995
    gedosan

    Tried a few plug-ins but no none of them removed it. I’ve come up with a solution to remove it from google at least – I created a page called /pages/ (it let me) and set that to nofollow, then googles removal tool let me remove it. That will do for now!

    Thanks for the help

    #916309
    Tom
    Lead Developer
    Lead Developer

    No problem – sorry we couldn’t figure it out.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.