[Resolved] Remove featured image from posts

Home Forums Support Remove featured image from posts

  • This topic has 5 replies, 2 voices, and was last updated 2 months ago by David.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1380451
    David

    Hiya,

    Having just started using GP recently, I’ve now written a couple of blog posts and used a featured image each time. They look fine on the Blog page, but they’re too zoomed in at the top of the Post pages themselves.

    I’ve searched through your Q and As I can’t find a simple solution, and I’ve now decided it would be best to not have an image at the top of the Post pages at all.

    But I can’t figure out how to remove the featured image either! I mean, without removing it from the Blog page too, which would be a shame as that page looks pretty smart.

    Things I’ve tried:

    Customize – Layout – Blog – Featured Images – Posts section – unticked ‘Display Featured Images’. But no difference. (Just to make sure, I’ve also tried unticking it in the archives and pages sections, to no avail).

    Whilst editing the Post in question (in what I think you call the Meta Layout section), I’ve ticked Disable Elements – Featured Image/Page Header, but that didn’t work. I’ve also tried ticking Header, just to see if Disable Elements is working, and it is, the header disappeared.

    Appearance – Elements – Blog Post Width – Disable Elements – Featured Image (tick), made no difference.

    Appearance – Elements – Blog Post Headers – Disable Elements – Featured Image (tick), made no difference.

    Appearance – Elements – Blog Post Headers – Page Hero – Disable Featured Image (tick), made no difference.

    Update – I think I’ve just figured out an acceptable workaround by deleting the top and bottom padding in Elements – Blog Post Headers – Page Hero – Padding. This makes the image disappear, and doesn’t leave too much whitespace. But I guess I’ll ask the question anyway, in case there’s a better answer and/or to help others in the future.

    Thanks,
    Dave

    #1380491
    David
    Staff
    Customer Support

    Hi there,

    you can just delete the Header Element or edit its Display Rules and remove the locations is not required.
    Then go to Customizer > Layout > Blog –> Featured Images >>> Posts – and tell it not to display the featured image.

    #1380512
    David

    Hi, thanks for the response.

    Is there a chance I’ll mess something else up if I alter the Blog Post Headers element? I’m guessing it is there for a reason?

    #1380542
    David
    Staff
    Customer Support

    Nope – its just there to create a Hero image out of your Posts featured image.
    If you want, instead of deleting it, Quick Edit it and change the status to Draft.

    #1380744
    David

    Ok, that makes sense. I reckon I’ll be ok now.

    Thanks Dave.

    Dave

    #1380747
    David
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.