[Resolved] Remove blog page header image

Home Forums Support [Resolved] Remove blog page header image

Home Forums Support Remove blog page header image

  • This topic has 9 replies, 2 voices, and was last updated 11 months ago by Ying.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #682822
    Tomasz

    Can you help me with removing blog page header image?
    I tried `.blog .site-header {
    display: none;
    }`
    but it doesn’t help. Perhaps it’s not header image then. Please, check my blog and you shall see the the problem right a way.

    GeneratePress 2.1.4
    #682830
    David
    Staff
    Customer Support

    Hi there,

    are you running GP Premium 1.7.2 (the latest version).
    If so go to Appearance > GeneratePress and activate the Elements module.
    The Appearance > Elements > New Layout. Select disable Header and then use the Display rules to assign that to the Blog.

    #790543
    Mark

    Select disable Header and then use the Display rules to assign that to the Blog.

    Just wondering how to do this?

    I’ve got a page header that constantly appears above the content container and I would like to stop it rendering entirely into the HTML code if possible rather than just hiding it via CSS.

    Thank you;

    Mark

    #790566
    Tom
    Lead Developer
    Lead Developer

    Hey Mark,

    This would be done using the Disable Elements and Elements modules: https://docs.generatepress.com/article/layout-element-overview/

    #791243
    Mark

    That worked like a charm.

    Thank You Tom.

    #791438
    Tom
    Lead Developer
    Lead Developer
    #1831471
    Avi

    There is no “disable elements” tab anymore. I’m trying to remove the feature image as well. Could you please help?

    #1831498
    Ying
    Staff
    Customer Support

    Disable elements is still there in layout element:
    https://www.screencast.com/t/gRIS4ny93M

    Make sure you’ve activated the Disable elements module at Appearance > GeneratePress.
    https://www.screencast.com/t/r3vxNowHJKdh

    #1831506
    Avi

    Cool, I added that.

    I added a new element, added a layout, clicked disable element, and checked feature image. I then selected display rules, location, blog, and pressed published. But I’m still seeing the header image in front of the H1 on blogs.

    #1831522
    Ying
    Staff
    Customer Support

    I’m confused, we might not talking about the same thing.

    Could you open a new topic and link us to your site using the private info field.

    Let me know ๐Ÿ™‚

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.