[Resolved] Recently my site does not fully load for up to 90 seconds

Home Forums Support Recently my site does not fully load for up to 90 seconds

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #313603
    Al

    First of all, awesome work, I love and support GP vs. any other theme out there. So thank you.
    Recently and without any changes to my site learrn.com the loading blue circle in the tab does not stop loading for between 10 to 90 seconds, which effecting my page speed and SEO with google.
    I have tried debugging it by de-activating plugins (and at one point all my plugins) same results.
    Only after I activate to 2017 theme it loads almost instantly.
    The status bar sometimes reads (connecting…) and sometimes (read fonts.gstatic.com).
    Any idea how to fix this issue so my site load time in gtmetrix is not 90+ seconds?

    Thank you in advance

    GeneratePress 1.3.46
    GP Premium 1.2.96
    #313619
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    This is the best way to look at it: https://tools.pingdom.com/#!/bEhoe0/http://learrn.com/

    If you look at the file requests, you’ll see times associated with them.

    First, it took your server 20 seconds to connect, wait and receive. That’s a hosting issue.

    Then this file: http://s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js took close to another 20 seconds to load.

    Then your stat counter took about 10 seconds.

    From the looks of things, your server is having some issues. If you’re on a shared server, I would request to be moved to a different server as a site on the same server might be hogging resources.

    Even regular files are taking far too long to load, which is why I’m leaning more towards a server thing.

    Are you adding any code in GP Hooks?

    #313622
    Al

    No codes in Hooks.
    I’m on a single EC2 on AWS, not shared. Would you suggest I do the following:
    1. Export my entire blog with all in one migration.
    2. terminate my ec2 instance.
    3. Lanuch a new instant>install wp> import my site?
    I can do that in terms of new server.
    However, I did deactivate the mailchimp plugin that include that image and also the statcounter plugin, but it’s still the same.
    If the steps above may work, I will do them. What do you think.
    Thank you Tom for the super fast reply.
    Al.

    #313623
    Tom
    Lead Developer
    Lead Developer

    Might be worth a shot. Worth trying a completely different server if you have one as well (localhost or otherwise).

    #313628
    Al

    OK, I will try that right now on a completely different region on AWS. see if that works and I will update you with the results.
    Thank you again.
    Al.

    #313642
    Al

    So, I have launched a brand new instant on my EC2 in a new aws region and imported everything using all in one migration plugin.
    Same results in browser and in pingdom.
    This does not make any sense to me as I have GP active on other sites with the mailchimp and statcounter plugins yet it loads fully almost instantly. Same goes for another wp with 2015 theme and all the same plugins, almost instant.
    From pingdom I see that “forget about shortcode buttons” plugin is also slow because of fontawesome. Yet same results when deactivating it.
    What else you think it could be?

    Al.

    #313697
    Tom
    Lead Developer
    Lead Developer

    What about when you deactivate GP Premium? Same issue?

    If it’s faster after deactivating GP Premium, try deactivate each individual add-on one by one.

    If it is somehow your GP installation, it would have to be some sort of server config issue or else you’d see this forum flooded with complaints, and the site we’re talking on would be very slow.

    You can try completely re-installing GP and GPP.

    #313955
    Al

    Hi Tom,
    So the only plugin I did not check was GPP. However, I have followed your instructions, and it was super fast loading (1.7 second).
    So I deactivated GPP individual add-on and I found out that “Menu Plus” was the one. With Menu plus deactivated the site is at less than 2 seconds load time.
    How do I fix this issue? Do I need to change my menu plus settings in customizer?
    I like menu plus, and like my setup now, but if an individual setting may make it faster while the add-on is active then I will sacrifice it.
    What’s your opinion?

    Thank you,
    Al.

    #313970
    Tom
    Lead Developer
    Lead Developer

    Huh, that’s not the add-on I would suspect, it doesn’t have any resource intensive options at all (unlike the image resizing sometimes in Blog/Page Header).

    Try exporting your menu plus settings and then deleting them (Appearance > GeneratePress). Any difference?

    #314429
    Al

    Hi Tom,
    It took me a while to realize that I needed the import/export add-on to be activated so I can export the settings of menu plus.
    However, after changing the settings yesterday to enable/disable sticky menu in layout. and trying to load the page again after cleaning cache and from my office computer, the load time is now as fast as it was when I disabled menu plus.
    I am puzzled of how that happened after being that way for a few weeks.
    So for now, I will mark this issue resolved but will do the export settings idea that you mentioned before if this happens again.
    Thank you for your awesome support.

    Best Regards,
    Al.

    #314490
    Tom
    Lead Developer
    Lead Developer

    Hmm that’s very strange – hearing that makes me lean even further to the server side of things.

    Glad it’s all working now 🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.