[Resolved] Read More Button after change over from Classic Editor to Guternberg

Home Forums Support Read More Button after change over from Classic Editor to Guternberg

This topic contains 13 replies, has 3 voices, and was last updated by  Leo 3 days, 8 hours ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1030870

    Sunil

    Hello Support,
    New Blog-Post in Generatepress does not show “Read More button”

    From the customizer options > Layout > Blog > Display read more as button is ‘Enabled”
    Content Type is also showing Excerpt with Excerpt word count = 35
    Tried disabling/enabling – Display read more button check-box…. ‘it has no effect on the new Gutenberg post”

    All the previous post was done while “WordPress Classic Editor” was “Enabled.”

    For the new Blog Post….I disabled the “WordPress Classic Editor, and “enabled” Gutenberg Editor.

    The older posts do show “Read More Button.” ……The problem is the new post in Gutenberg does not.

    Help will be appreciated asap please!

    Thanks

    #1030891

    Leo Customer Support

    Hi there,

    All of our sites in the library are using Gutenberg and excerpt is all working correctly.

    Are you referring to the first post? Looks like it’s using custom excerpt.

    If so this should help:
    https://docs.generatepress.com/article/activating-read-custom-excerpt/

    Let me know 🙂

    #1030940

    Sunil

    Sorry, I forgot to remove the “excerpt (optional)” inside Gutenberg, I was running the test to see if it would fix.

    The problem is still there when I remove “Write an excerpt (optional)” inside Gutenberg.

    Now after removing it, the excerpt is empty, it’s not getting from the post…..(see the link provided earlier)

    I also double checked, WP Settings > Reading > Select Summary is enabled.

    Please help and advice.

    Thanks

    #1031439

    Tom Lead Developer

    Hi there,

    Can you make sure the excerpt field is completely empty? There might be some empty spaces in there which are preventing the automatic excerpt from showing.

    Let me know 🙂

    #1031636

    Sunil

    Thanks for replying Tom,

    Once again, I double checked it and it’s completely empty. No spaces

    I like to get this resolved, because I have a ppc marketing campaign on hold.

    Is there a private way to provide you with WP-Admin Access ?

    Let me know.

    #1031658

    Leo Customer Support

    Can you first try creating a new post first without adding anything in the custom excerpt box? Just add a couple paragraphs blocks without using anything else.

    We haven’t had this issue reported before so it must be something specific to that post.

    Let me know 🙂

    #1031680

    Sunil

    Leo thanks for your reply.
    The test you suggested proved useful.

    I tested it with default “paragraph-block” and it worked!
    Therefore it’s safer to use the default Gutenberg-paragraph block on its own.

    The problem happens when the “default Gutenberg-paragraph block” is nested inside the “Universal Addon for Gutenberg- section block”

    With the default paragraph-block, excerpts work well.

    But!
    There is one issue though….

    If you open the post link, you’ll see the “width” of the first 4 paragraphs “not aligned” to rest of the page content.

    I’m using 900px width with section-blocks for Universal Addon for Gruenberg plugin.

    == > Can you give me the css for first 4 paragraphs so it be aligned with rest of the page content?

    Side note: I’m craving desperately for Generatepress Gutenberg-Blocks!!!!

    #1031702

    Leo Customer Support

    You can try giving those blocks a custom class then target that class with the same CSS:
    https://www.screencast.com/t/nW6zNKeTqcCY

    #1031746

    Sunil

    Thanks for your reply,

    Sydney, Australia and your USA are on completely different time zone.

    I tried doing as you advised, it does not work. And there’s 100% likelihood I am doing it wrong!

    [1]. This is what I did.

    On the right side > Advanced Tab
    In the > Additional CSS Class: .post-paragraph-1

    [2]. Inside Simple CSS, I added

    .post-paragraph-1 {
    max-width:: 800px;
    margin-left: auto;
    margin-right: auto;
    }

    [3]. Instead of leaving it empty, I also, for the opening first 4 paragraph lines, I made sure each one was populated….
    On the right side > Advanced Tab
    In the > Additional CSS Class: .post-paragraph-1

    It did not work.

    Please help and assist.

    Thanks

    #1032220

    Leo Customer Support

    Can I make a suggestion that this just isn’t the best way to achieve a layout like this?

    Have you checked with the plugin author to see why their content won’t show in excerpt?

    What if you just use the custom excerpt field instead and use the snippet above to activate read more?

    #1032481

    Sunil

    Thanks Leo,

    You guys at Generatepress always (so fat) give valuable advise.

    I have done as you suggested;

    [1]. Did custom excerpt
    [2]. modified function.php on GP-Child Theme

    Its working all good.

    For the content “format” on the single post, I have again gone back and restored the UAG-Section-block to make the content alignment consistent with rest of the post.

    But….I have not contact the UAG-Plugin-Support !…..This leads me to one final question…..Please do answer………

    I have read somewhere that Generatepress will release its own “Gutenberg-BlocK,” please give some update and envisaged release date????

    Generatepress Native Gutenberg-Blocks will be just “awesome and the ultimate answer.”

    I also will not be using Beaver Builder Premium plugin from now on wards.

    Please do let me know…..

    #1032499

    Leo Customer Support

    The alpha version should be out soon.

    Thanks for your patience! It will be awesome 🙂

    #1032513

    Sunil

    Thanks Leo….

    I look forward to GeneratePress Native Gutenberg !

    #1032901

    Leo Customer Support
Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.