[Resolved] quote block not responding as expected to changing settings

Home Forums Support quote block not responding as expected to changing settings

  • This topic has 3 replies, 2 voices, and was last updated 1 year ago by David.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1010546
    Elisabeth

    Hello,
    I’m working on a site using GP Pro and I would like to include quotes using the Gutenberg quote block.
    Contact in the quote block appears in the back end and I’m able to edit/style the quote by choosing italics etc but in the front end it remains totally unresponsive displaying all italics whatever I do.

    It offers ‘default’ and ‘large’ and it does respond (in terms of size) when I change those, but even when the main quote is italics in the back end and I try and make the citation plain it only gives me italics. In fact, it won’t even let me unitalicise the quote itself, even in the back end. the ‘i’ button appears clickable but nothing happens. When I try and change the citation the italics appear/disappear from the back end but the front end quote appears exactly as before – all italics.
    I’d also like to change the font size to make it smaller but I guess that’s an ‘additional CSS’ issue – the quote block itself not responding to the standard settings/editing options seems a bit more fundamental.

    Any tips on how to overcome this?
    Thanks
    Elisabeth
    PS Site is behind a construction page at the moment.

    #1010552
    David
    Staff
    Customer Support

    Hi there,

    some of the blocks use what Gutenberg calls helper classes. We omitted some of the helper class styles from the theme, as we were expecting the blocks to change there method – so best way is to use a little CSS. These two rules will do the text for you:

    .wp-block-quote p {
        font-size: 16px !important;
        font-style: italic !important;
    }
    
    .wp-block-quote cite {
        font-size: 12px !important;
        font-style: normal;
    }

    It may needs the !important depending on what style you choose in the editor.
    Let us know if you have a particular style you want to achieve and i can help.

    #1011286
    Elisabeth

    That explains it. Thanks.
    Elisabeth

    #1011342
    David
    Staff
    Customer Support
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.