[Resolved] Proportional image scaling

Home Forums Support Proportional image scaling

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #110059
    Mikuak Rai

    Hi GP… When I upload images into “Media” I’m being given a few default image sizes. I want to ask how can I make it so that images I apply to my posts can be scaled proportionally, instead of by the 300×300 or 1024×1024 default values I’m currently being given? Is there a change in code you could suggest I apply that will work for all images I’m uploading when using my GeneratePress theme? Thanks!

    #110105
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Try going to “Settings > Media”.

    Make sure your height for Medium and Large is set to “0”.

    That should tell WP to resize those sizes proportionally.

    Let me know 🙂

    #110184
    Mikuak Rai

    Hey Tom… Thanks for the prompt response. So I went ahead and adjusted the settings in “Media” as you suggested. I then set up a completely new test page, and it is still only allowing the usual 300×300 (medium) and 1024×1024 (large) sizes for images (in additional to full size and thumbnail options) when attempting to “Add Media” in the post/page. Is there any other workaround? Would this be something I have to change in the theme stylesheet to override these unwanted default sizes?

    Thanks again!

    #110195
    Tom
    Lead Developer
    Lead Developer

    GP doesn’t actually do anything to the default WordPress image sizes, so there’s nothing on the theme end of things to modify.

    What you may have to do after changing the dimensions in “Settings > Media” is regenerate your thumbnails using a plugin like this: https://wordpress.org/plugins/force-regenerate-thumbnails/

    #110208
    Mikuak Rai

    Gotcha. I’ll go ahead and give that plugin a shot. Thanks for your helpful feedback!

    Best Regards!

    #110213
    Tom
    Lead Developer
    Lead Developer

    No problem! Let me know how it goes 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.