Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Problems with Google Crawl

Home Forums Support Problems with Google Crawl

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #498303
    Wayne

    So, today Yoast reported that my main page (https://www.phoenixcentre.com/blog/) was unreachable by Google.
    I did some testing; renamed robots.txt in /blog/. same with .htaccess. Neither helped.
    I contacted SiteGround tech support. After a bit of time, they said that they disabled GP Premium, and indexing started working.
    I ran another fetch and render, and now I receive “complete.”
    Curious about what in the plugin might be blocking Google.
    Wayne

    GeneratePress 2.0.2
    GP Premium 1.5.6
    #498598
    Tom
    Lead Developer
    Lead Developer

    Hi Wayne,

    GP Premium won’t block anything by default.

    Perhaps you have something inside GP Hooks which is blocking robots?

    #498977
    Wayne

    I reactivated the plugin and disabled hooks, and things are OK, which, again, is weird, as nothing has changed for months in “hooks” — all that’s in there is a line in footer to show copyright as 2009-2018 (or whatever.)
    Thanks for the suggestion

    #499268
    Tom
    Lead Developer
    Lead Developer

    So having hooks activated blocks the spiders? Nothing at all in the wp_head hook?

    #499289
    Wayne

    I reactivated hooks to have a look. The only line in use is this in the footer:
    <p align=”center”> <?php bloginfo(‘name’); ?> <?php echo my_copyright(); ?> All rights reserved</p>

    HOWEVER, I headed over to Google and retested the main page, and got a “complete” with hooks on. I also turned on one other (page header) that I’d turned off. Tested again, and all is well.

    This is so very weird. The only real changes were:
    1) I removed the normal WP robots.txt in favour of the “blank’ one suggested by Yoast, and
    2) SiteGround turned off your GP Plugin.
    3) Restoring the plugin initially failed, until I disabled “hooks.”
    4) I’ve re-enabled “hooks” and Google can index.

    Weird.

    Wayne

    #499292
    Tom
    Lead Developer
    Lead Developer

    Very weird – there definitely isn’t anything inside GP Premium or GP that would block robots, or else we’d have tons of complaints (and this site we’re on wouldn’t be indexed).

    Perhaps you just had some sort of caching issue going on?

    Glad it’s all working now 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.