[Resolved] Problem with widget in header sidebar

Home Forums Support Problem with widget in header sidebar

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #117324
    Ian

    Hi Tom, it’s me again.

    All was working well on my blog http://factoringblog.co.uk/ until this weekend. I upgraded to the latest version of the theme and added a new plugin whereupon the problems started. The site still displayed but I couldn’t access the admin dashboard and the web host had to disable all of the plugins and re-install a backed up version of GeneratePress.

    I have now upgraded again to the current version and have tried to re-enable the plugins one by one but one is causing problems now although it worked well until the weekend.

    If I enable “Easy Social Icons” and put the resulting widget into the right hand sidebar it seems to work. The problem is that I want it in the header sidebar which is where it was but if I try to install it there I get the following error message on public display:-

    “Notice: Undefined index: title in /home6/ianj4750/public_html/wp-content/plugins/easy-social-icons/easy-social-icons.php on line 874

    I have tried to put other widgets in the header sidebar as a test and they all seem to work properly – but not the actual one that I want.

    #117368
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The undefined index PHP notice is a coding error in that plugin – you’ll have to report it to the developers. It basically means there’s a $title variable which doesn’t have a value, and they haven’t supplied a backup in case there’s no title.

    What happens when you give the widget a title?

    #117542
    Ian

    This is most odd as I went to try out your suggestion this morning and the plugin worked perfectly yet it gave me all sorts of problems yesterday and even a friend who has quite a bit of PHP knowledge couldn’t get it to behave.

    Must have just been a glitch in the Matrix

    Thanks again Ton

    #117556
    Tom
    Lead Developer
    Lead Developer

    Weird, glad it’s working now 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.