[Resolved] Problem with the Header position

Home Forums Support Problem with the Header position

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1006202

    Sorry, I don’t write English very well…
    I have this configuration: GeneratePress: 2.3.2 version, GP Premium: 1.8.3 version
    And I used the demo site “Wordsmith” to begin my site, how base. I use the SiteOrigin Editor in the Page Builder (no Hero Header) for the Header.
    The problem that I found is the Header position, is on the right every time when I see my site in a computer, I can put it on the left, centred or right, but in remains on the right part. However, I can see it perfectly in the middle of my mobile screen.
    I think the first (phantom) column is referent to Site Title and Tagline (or another thing what I don’t find), and the second for the Header. When I enable both (Site Title/Tagline and the Header) I see how two columns. When I disable de Site Title/Tagline, the Header stays on the right, not in the center of the screen, and then I see this column space apparently empty (with no text), only in computer vision, however in mobile It’s ok. [here an image]
    I need to see the Header in the center of the screen not on the right in my computer, with the Site Title and Tagline disabled.

    A lot of thanks for your help! 🙂


    Customer Support

    Hi there,

    I tested several browsers and all of them are showing center:

    Using browser resizing didn’t show any issues either.

    Which browser are you using? Have you tried clearing browser cache?

    Let me know 🙂


    Hi Leo,

    Sorry, at that moment the Site Title and Tagline were enable and the Header disable.

    Now, I change the configuration: Header enable and Site Title/Tagline disable. You can check now the issue.


    Customer Support

    Hi there,

    its because you’re using the header widget, which by default is set to Float Right and only occupy 50% of the screen. This CSS will make it centered:

    .header-widget {
        float: none;
        max-width: 100%;


    David, Leo, thank you very much. It works! 🙂

    Customer Support

    Glad we could be of help

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.