[Resolved] Problem with icons (font awesome?)

Home Forums Support [Resolved] Problem with icons (font awesome?)

Home Forums Support Problem with icons (font awesome?)

  • This topic has 6 replies, 3 voices, and was last updated 9 years ago by Tom.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #115534
    Jakob Smith

    Hello,

    I’m having a problem with for example the search icon, which should show up in the navigation, when I have enabled it in the settings.

    It looks like this:
    https://dl.dropboxusercontent.com/u/20773034/screenshot-medlem%20ortodoks%20dk%202015-06-19%2013-06-01.png

    And also below the posts, I have some problems:
    https://dl.dropboxusercontent.com/u/20773034/screenshot-medlem%20ortodoks%20dk%202015-06-19%2013-06-37.png

    I use the Generatepress child theme provided here on the site.

    Let me know how I can troubleshoot this.

    #115551
    Jakob Smith

    I had a closer look in the browser console and I see errors about the fonts not downloading. Why would that be?:

    downloadable font: download failed (font-family: “FontAwesome” style:normal weight:normal stretch:normal src index:2): status=2147746065 source: [site removed]/wp-content/themes/generatepress/fonts/fontawesome-webfont.woff?v=4.3.0 font-awesome.min.css:4:14

    downloadable font: download failed (font-family: “FontAwesome” style:normal weight:normal stretch:normal src index:3): status=2147746065 source: [site removed]/wp-content/themes/generatepress/fonts/fontawesome-webfont.ttf?v=4.3.0 font-awesome.min.css:4:14

    downloadable font: no supported format found (font-family: “FontAwesome” style:normal weight:normal stretch:normal src index:5) source: (end of source list) font-awesome.min.css:4:14

    #115568
    Tom
    Lead Developer
    Lead Developer
    #116018
    Jakob Smith

    I can find that setting in about:config, but can’t edit it. But this would not be a good solution because the problem is the same across browsers.

    So maybe a server setting needs to be changed? I’ve checked the mime types and both woff and ttf are added.

    #116110
    Tom
    Lead Developer
    Lead Developer

    Can you link me to the site so I can see if the same thing happens to me? Is this only happening in Firefox?

    #117858
    Jakob Smith

    I found the solution just minutes ago.

    The culprit was an .htaccess in wp-content, which only allowed certain filetypes to be downloaded.

    So, I changed it from

    Order Allow,Deny
    Deny from all
    <Files ~ ".(css|jpe?g|jpg|JPG|png|gif|js|pdf|swf|php|mp3|flv|html|xml)$">
    Allow from all
    </Files>

    to

    Order Allow,Deny
    Deny from all
    <Files ~ ".(css|jpe?g|jpg|JPG|png|gif|js|pdf|swf|php|mp3|flv|html|xml|woff|ttf|eot|woff2)$">
    Allow from all
    </Files>

    and now it works ๐Ÿ™‚

    I was led to this conclusion by this thread:
    https://wordpress.org/support/topic/default-free-icon-not-showing#post-6594266

    #117864
    Tom
    Lead Developer
    Lead Developer

    Nice! Thanks for sharing! It should be helpful to others ๐Ÿ™‚

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.