[Resolved] Post still contain footer even after disable + entry-meta

Home Forums Support Post still contain footer even after disable + entry-meta

This topic contains 7 replies, has 4 voices, and was last updated by  Tom 1 month, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1184153

    Adam

    Hi,

    in post, I disabled footer, set full width, and added custom footer via divi. The problem is the style from all.min.css:
    .one-container:not(.page) .inside-article {
    padding: 0 0 30px 0;
    }

    and element on the bottom of the page, that survided disabling the footer:
    <footer class=”entry-meta”><nav id=”nav-below” class=”post-navigation”> <span class=”screen-reader-text”>Post navigation</span></nav><!– #nav-below –></footer>

    In the result, the website have a big white space bellow my custom footer. My custom footer works well on regular pages, the problem only occours in posts.

    Can you please tell, how can I remove this white stripe on the bottom of the page in a clean way?

    ps. I’m a developer.

    Best Regards,
    Adam

    #1184170

    Leo Customer Support

    Hi there,

    Any chance you can link us to the site in question?

    You can edit the original topic and use the private URL field.

    Let me know 🙂

    #1184465

    Adam

    Hi Leo,

    not really.

    It’s very easy to reproduce using the settings I provided.

    Page type: blog post
    Disabled elements: footer

    To see big white stripe on the button, please add some black row on the bottom. The easiest way to do that is with some page builder like divi or elementor.

    #1184956

    Tom Lead Developer

    Hi there,

    Have you tried disabling the post navigation option in Customize > Layout > Blog?

    #1185251

    Adam

    Post navigation is already disabled. One cause of the issue was ‘display post tags’ active. I added

    body.one-container:not(.page) .inside-article {
    padding-bottom:0;
    }

    to fix problem with the padding, it’s good enough so far.

    Thanks.

    #1185403

    Leo Customer Support

    That issue can potentially be solved with using page builder container as well:
    https://docs.generatepress.com/article/page-builder-container/

    Tough to tell without seeing the site live.

    #1247808

    Natalie

    same issue here. inside-article in ‘posts’ gets a 30px bottom padding but .inside-article in pages doesn’t.
    I have used a layout element to set entire site to ‘full-width’

    As woocommerce product pages are ‘posts’, I have more padding at the bottom of product pages than I do at the bottom of other ‘pages’ on my site.

    I have used css to adjust similar to what Adam has done

    #1248557

    Tom Lead Developer

    Thanks for the heads up – I’ll look into it 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.