Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Post and Page titles not showing

Home Forums Support Post and Page titles not showing

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #31971
    Gary Nixon

    Tom,

    Love the theme and all the addons. Using them almost exclusively.

    That being said, I have a site where the post and page titles are not showing and was wondering if you could help me out. When you get a chance, please look at http://www.nixonfs.com

    Thanks for your help.

    #31973
    Tom
    Lead Developer
    Lead Developer

    You’re hiding the post title with CSS in your child theme.

    Go to “Appearance > Editor” and look for this:

    .entry-title {
        display: none;
    }

    Delete it, and you should be good to go ๐Ÿ™‚

    #44906
    Christian

    Tom I’m having problems with the tabs after migrating them from localhost to my site.
    Inside my localhost I have several tabs with images, however after migration to bluehost.com they won’t appear.

    #44907
    Christian

    Tom Iโ€™m having problems with the tabs after migrating them from localhost to my site.
    Inside my localhost I have several tabs with images, however after migration to bluehost.com they wonโ€™t appear.
    Please check out my site http://christianpisc.com. Thanks in Advance

    #44947
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Where are these images supposed to be?

    If I had to guess, it would be that when you migrated, the URLs to the images didn’t change to your domain name.

    You may want to try a plugin like this: https://wordpress.org/plugins/velvet-blues-update-urls/

    It will allow you to replace all instances of http://localhost to your new URL.

    Let me know ๐Ÿ™‚

    #211038
    Jessica

    I am having the same problem, but I have no style containing:

    .entry-title {
        display: none;
    }

    My other GP site is showing page titles so I’m not sure what could have happened.

    #211041
    Jessica

    Appears that the conflict is: If I have a featured image displayed on the page, the page title disappears. The pages with no featured image show the page title. Not sure what the conflict is.

    I have this in my functions file to show the featured image:

    add_image_size( 'featured-image', 945, 400, true );
    add_filter( 'generate_page_header_default_size','generate_change_page_header_size' );
    function generate_change_page_header_size()
    {
        return 'featured-image';
    }

    I don’t see anything relating to “remove” or “replace” so I’m stumped.

    #211043
    Jessica

    Alright… so, I’ve narrowed this down by trial and error, and discovered what appears to be the conflict:

    The featured image itself is not the conflict. However, when I enable the use of “Sections” on the page, that is when the page title disappears (despite not having disabled the page title). That option is definitely not enabled. I have yet to even use that add-on’s options.

    Thus, the ONLY difference between the pages that show the title and not, is the use of sections on the ones that are hiding it.

    How can I override this so I can use/see both?

    #211057
    Tom
    Lead Developer
    Lead Developer

    Hi Jessica,

    Page titles aren’t displayed by default with Sections, as it would look pretty ugly to have a stray title above your sections.

    You can add your own page title into your first section – simply type it it and wrap it in a Heading 1 ๐Ÿ™‚

    #211062
    Jessica

    Page titles arenโ€™t displayed by default with Sections, as it would look pretty ugly to have a stray title above your sections.

    I’d say “ugly” is subjective. When a designed and styled properly, nothing needs to looks ugly. I know how I want to style and position the title but since it’s been removed for me, I’m stuck. :/

    You can add your own page title into your first section โ€“ simply type it it and wrap it in a Heading 1

    Starting off with at least 10 pages, having the page title appear by default is far more efficient, allowing me the flexibility to style it as needed. I’d prefer not to have to choose one or the other. This will create more manual work + risking the client “messing up” what is on the page (which is already hard enough to control regardless of user roles assigned).

    How do I override this so I can see the page title & use sections? I would prefer to choose when I don’t want the page title to show.

    #211064
    Tom
    Lead Developer
    Lead Developer

    In order for it to look good, you’ll need to apply CSS to it so it matches the rest of your page style.

    You can add it with a function like this:

    add_action( 'generate_before_main_content','generate_add_sections_title' );
    function generate_add_sections_title()
    {
    	global $post;
    	$use_sections = ( isset( $post ) ) ? get_post_meta( $post->ID, '_generate_use_sections', TRUE) : '';
    	
    	if ( ! $use_sections )
    		return;
    	
    	if ( generate_show_title() ) : ?>
    		<header class="entry-header">
    			<?php the_title( '<h1 class="entry-title" itemprop="headline">', '</h1>' ); ?>
    		</header><!-- .entry-header -->
    	<?php endif;
    }
    #506640
    Boris

    Hi!

    I have a situation where only the “home” page of the site doesn’t display the page title in the browser TAB.
    When it’s loading it’s OK – the real title is displayed. But when finishes loading then what is displayed is the following text: Homepage Title
    The real title is gone.

    Other subpages are OK.

    #507077
    Leo
    Staff
    Customer Support

    Hi there,

    Can you open a new topic and link us to the page in question?

    Thanks!

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.