Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Support request] Plugin update & plugin install: "The connection was reset" But localhost/ works

Home Forums Support Plugin update & plugin install: "The connection was reset" But localhost/ works

  • This topic has 1 reply, 2 voices, and was last updated 3 years ago by Tom.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #437505
    John

    I am using localhost with Windows 7 service pack 1 with all updates, Apache 2.4, MySQL 5.7, WordPress 4.9.
    Briefly: attempts to update to GP Premium 1.5.5 or reinstall GP Premium fail with “Connection was reset…” I can install other plugins to WordPress 2017 Theme. BUT if I change that site to GeneratePress theme and attempt to install GP Premium 1.5.5, fails with the “connection was reset” error message.
    Details Below:
    Downloaded GP Premium 1.5.5 .zip from GeneratePress.com.
    I Cannot update GP Premium plugin from 1.5.4 to 1.5.5. Update fails with message: “The connection was reset. The connection to the server was reset while the page was loading. The site could be temporarily unavailable or too busy. Try again in a few moments. If you are unable to load any pages, check your computer’s network connection. If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.”
    I deactivated GP Premium 1.5.4. Then deleted GP Premium 1.5.4. Logged out of site. Logged into site.
    Install New Plug In > Upload > Browse > and I located the downloaded .zip for GP Premium 1.5.5. > Install failed with same message.
    I logged on to a different WordPress site using 2017 theme. Tried installing “Duplicate Post” plugin from downloaded zip file. SUCCESS! Installed “Duplicate Post” Plugin.
    Switched site to Generate Press Theme. Tried to install GP Premium 1.5.5 from downloaded .zip file. FAIL with the same “connection reset” message.
    WordPress.com site was pretty useless about “Connection reset” error. Google search on “plugin” “connection reset” produced useless advice.
    Basically, I just want things to work.
    So, I probably have not provided the correct information to ask for help.
    I do not know what went wrong, why other themes and plugins work, but GeneratePress and GP Premium do not work. At least GP Premium 1.5.4 worked. Now I cannot re-install the GP Premium 1.5.4 plugin, same error message.
    So, somewhere in the MySQL database I need to delete or change or something. Or a new error file is now hidden somewhere in the WordPress files (“maintenance” file was not added.) and I have to delete or change something.
    I removed all other plug ins before trying to update GP Premium 1.5.4.

    GeneratePress 1.4
    #437508
    Tom
    Lead Developer
    Lead Developer

    Hmm, haven’t seen that error before.

    Can you try increasing your PHP memory limit?: https://docs.generatepress.com/article/increasing-php-memory-limit/

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.