[Resolved] Plugin-Theme Conflict

Home Forums Support Plugin-Theme Conflict

  • This topic has 14 replies, 5 voices, and was last updated 11 months ago by Tom.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #994254
    GG

    Hi. I was working in the customizer when it suddenly began refreshing every two seconds. I narrowed down the problem to GP Theme Conflict with this plugin https://wordpress.org/plugins/wp-external-links/. Using a default theme like twenty 19 makes the problem go away. The problem seems to be the free GP and the plugin. Not sure how it has begun coz it was just sudden. I cleared website and browser cache, changed browsers, deactivated all plugins, tried incognito, etc. but the problem is still there.

    #994466
    David
    Staff
    Customer Support

    Hi there,

    are you using a GP Child theme with any custom functions within that or GP Hooks?
    If so first try eliminating that as the conflict.

    Let us know.

    #994521
    GG

    Hi. No child theme in use. As stated, the issue also happens with GP premium and code snippets deactivated (all plugins). The console tabs show this code which reloads endlessly with every customiser self-refresh http://prntscr.com/oy64lz

    #994744
    Leo
    Staff
    Customer Support

    Hi there,

    I just installed/activated the plugin and didn’t experience the issue at all.

    Do you have to change certain things in the customizer for the issue to happen?

    #994995
    GG

    I am not sure coz I was working with the additional CSS area when the whole issue began. No changes were made anywhere else. It was just a random thing.

    #995000
    Leo
    Staff
    Customer Support

    Strange.

    Can you send us the dashboard access to test?

    Please disable all activated plugins.

    You can send the dashboard access using Account Issue here:
    https://generatepress.com/contact/

    Please include the following information:
    – The URL of this topic.
    – Login URL.
    – Username and password.

    #995007
    GG

    I have sent the details. just deactivate the maintenance plugin and activate the external links plugin by itself and see what I mean in the customiser. (Sorry I forgot to use accounts issue and used presale instead).

    #995022
    Tom
    Lead Developer
    Lead Developer

    Can’t replicate this on my end either.

    Have you contacted the plugin author? They might have an idea what could be causing this.

    There shouldn’t be anything in GP itself. It looks like there’s a 404 happening over and over again if you open the Console.

    #995026
    GG

    I have just sent the issue to the plugin author. I decided to ask here first coz I saw only GP theme is affected. I will get back if I get an answer.

    #995041
    Tom
    Lead Developer
    Lead Developer

    Sounds good – hopefully they’ve had something similar happen before.

    #995045
    GG

    I restored yesterday’s database which seems to have resolved the issue. Let me see if I can get a response in the meantime. Cheers and thanks.

    #1051142
    Matthias

    Hi,
    I do have the same problem on two domains. The customizer constantly refreshes, if I deactivate WP External Links the issue is gone. There seems to be some sort of conflict.
    As we rely heavily on WP External Links, what would you recommend to do as a next step?
    Thank you,
    Matthias

    The console reports:
    Uncaught Error: react-modal: No elements were found for selector #wprm-admin-modal.
    at c (admin-modal.js:92)
    at Object.t.setElement (admin-modal.js:92)
    at Function.value (admin-modal.js:92)
    at Object.<anonymous> (admin-modal.js:92)
    at Object.<anonymous> (admin-modal.js:92)
    at n (admin-modal.js:1)
    at Module.<anonymous> (admin-modal.js:92)
    at Module.<anonymous> (admin-modal.js:92)
    at n (admin-modal.js:1)
    at admin-modal.js:1
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:3565 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:3565
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4777 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4777
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4974 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4974
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5165 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5165
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5357 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5357
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5497 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5497
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5621 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5621
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5839 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5839

    I have also reported the problem here:
    https://wordpress.org/support/topic/customizer-constantly-refreshing-generatepress-theme/

    #1051468
    Tom
    Lead Developer
    Lead Developer

    I can’t think of anything on the GP side of things that would cause an issue like this. Hopefully they’re able to pinpoint things on their end 🙂

    #1051475
    Matthias

    Thank you Tom, I thought so… Will keep you posted!
    all the best,
    M

    #1051668
    Tom
    Lead Developer
    Lead Developer
Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.