[Resolved] Ploblems with arrows

Home Forums Support Ploblems with arrows

  • This topic has 5 replies, 2 voices, and was last updated 1 year ago by David.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1007393
    Guillem

    Good day,

    I have problems with the arrows of the slides block. Whatever the block-plugin I can not see the arrows. That’s why I think it’s a template theme.

    You can see the example in this link:

    https://celtaproba.pilvia.site/

    Any idea of how I can undermine the problem.

    Thank you so much,
    Guillem
    Excuse me for my English.

    #1007445
    David
    Staff
    Customer Support

    Hi there,

    by inspecting the Slick Slider i can see the Javascript which looks like this:

    <script>;jQuery(document).ready(function($){$('.slick-slider-5550').slick({dots:false,infinite:true,speed:1000,arrows:false,autoplay:true,autoplaySpeed:5000,fade:false,slidesToShow:1,slidesToScroll:1,lazyLoad:'ondemand',mobileFirst:true});});</script>

    The issue is this argument: arrows:false
    This is removing the default navigation arrows.

    Are you using a plugin to add the slider? Is this an option?

    #1007631
    Guillem

    Sorry,

    I wanted to say the carrousels found below the page. They are two different blocks of gutenberg and both have visualization problems with the arrows.

    https://celtaproba.pilvia.site/

    Thanks

    #1007652
    David
    Staff
    Customer Support

    My apologies – i should have looked at the rest of the page.
    So there is a plugin called: “Seo Slider”? Which is adding this CSS:

    .slick-arrow {
        position: absolute;
        z-index: 1;
        top: calc(50% - 30px);
        padding: 0;
        margin: 0;
        text-indent: -9999px; /* This is the issue */
        line-height: 0;
        height: 30px;
        width: 30px;
        background: transparent;
        border: none;
        border-radius: 0;
        background-image: url("../images/arrow.svg");
        background-color: rgba(10,20,30,0.2);
        background-size: 10px;
        background-repeat: no-repeat;
        background-position: center;
    }

    The line i have commented is causing the issue.
    Not sure if you can disable that plugin – if you can’t then add this CSS:

    .slick-arrow {
        text-indent: 0 !important;
    }
    #1007675
    Guillem

    Thank you so much,

    Theme solved. With the CSS you can see the arrows.

    Guillem

    #1007683
    David
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.