Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Please help – Bootstrap not working!

Home Forums Support Please help – Bootstrap not working!

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #208289
    Kim

    So I updated GeneratePress today, and everything has gone wrong!

    None of my Bootstrap or animated elements are working. The site is now also extremely slow to load.

    Please help – I think I might need to roll back my version of GP!

    http://www.smartspecialisationhub.org

    #208295
    Tom
    Lead Developer
    Lead Developer

    Hi Kim,

    Super strange, let’s debug and figure out what’s going on.

    Try disabling Photon in “Jetpack > Settings”.

    I ran a test on your site, and it looks like Photon is returning a 504 bad gateway on one of your images, causing it to take over 10 seconds to load that single image.

    Another thing I noticed, this file: https://cdn.rawgit.com/twbs/bootstrap/v4-dev/dist/js/bootstrap.js

    It’s loading way too high in your source, above where jQuery is loaded, which won’t work.

    How are you adding the above file? GP Hooks? If so, load it in the “wp_footer” hook.

    If none of the above helps, let’s go through the following process:

    1. Do you have a caching plugin? If so, can you try clearing the cache?
    2. What happens if you deactivate all non-GP plugins? Still the same issue?
    3. What if you deactivate GP Premium? Is it the issue gone?
    4. If so, re-activate GP Premium and go to “Appearance > GeneratePress”. Deactivate the add-ons you have activated on by one. Does the site speed up once after deactivating a specific add-on?

    #208340
    Kim

    All sorted!

    Disabled Photon and moved the JS to wp_footer.

    Thank you! 🙂

    #208341
    Tom
    Lead Developer
    Lead Developer
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.