[Resolved] php fatal error

Home Forums Support php fatal error

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #990431
    Ewout

    Hiya,

    im building in the generate press them with the Divi builder.

    everything works fine, but as soon as i am trying to add a blog gallery the site is responding with the following error:

    [Thu Aug 22 11:58:58.735779 2019] [fcgid:warn] [pid 27463] [client 85.148.53.14:60964] mod_fcgid: stderr: PHP Fatal error: Maximum execution time of 0 seconds exceeded in /home/tyker-concept/public_html/wp-content/plugins/divi-builder/includes/builder/module/settings/Migration.php on line 71, referer: http://tyker-concept.nl/robot-plotter/

    This is only on the news/nieuws page where i add an overview of the blog posts.

    The max execution time is already set to ‘0’

    And according to the error log it has to do with the divi builder. But everything worked fine together until i make the blog gallery page.

    I already asked divi, they said with the latest update this should be working.

    My question now is, has this anything to do with the combination of Divi builder and generate press or do i have(for example) to deactivate the blog feature of Generatepress tot solve this error?

    Kind regards,

    Ewout

    #990508
    David
    Staff
    Customer Support

    Hi there,

    if you’re trying to edit the Blog page ie. the one set in Settings > Reading > Display Posts then you’re are not able to edit this page with or without Divi. Let me know.

    #990516
    Ewout

    Hi David,

    Home page shows a static page so nat a blog page.

    I set no page for blog pages(-selelt-), is that the right option?

    Kind regards,

    Ewout

    #990544
    David
    Staff
    Customer Support

    I can’t see that this is anything related to GP as it doesn’t know of the Page Builders existence. You can try disabling the Blog module.

    #990565
    Ewout

    Hi David,

    I already tried that. But that doesnt fix it:(

    everything works fine, but as soon as i am trying to add a blog gallery the site is responding with the following error:

    [Thu Aug 22 11:58:58.735779 2019] [fcgid:warn] [pid 27463] [client 85.148.53.14:60964] mod_fcgid: stderr: PHP Fatal error: Maximum execution time of 0 seconds exceeded in /home/tyker-concept/public_html/wp-content/plugins/divi-builder/includes/builder/module/settings/Migration.php on line 71, referer: http://tyker-concept.nl/robot-plotter/

    I looked in in it and around line 71 the following code is in php:

    // For the BB…
    if ( ! in_array( $old_name, self::$_bb_excluded_name_changes ) ) {
    self::$migrated[‘field_name_changes’][ $module_slug ][ $old_name ] = array(
    ‘new_name’ => $new_name,
    ‘version’ => $version,
    );

    dont know what it does, but this seems to be the problem. I know its the divi builder plugin, but maybe you are familiar with this. If not, big bummer for me:)

    Kind regards,
    Ewout

    #990582
    David
    Staff
    Customer Support

    I am not familiar with Divi.
    You can test to see if there is an issue by switching to the TwentySeventeen theme – this will eliminate any theme related issues.

    #990596
    Ewout

    Thanks i will try that, if it works i wil contact Divi again.

    THanks for your help David.

    Kind regards,

    Ewout

    #990770
    David
    Staff
    Customer Support

    Let us know if works with TwentySeventeen

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.