[Resolved] PHP Error in GP Premium

Home Forums Support PHP Error in GP Premium

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #925312
    Scott

    See an error like this on several sites:
    [10-Jun-2019 23:54:21 UTC] PHP Warning: Creating default object from empty value in /home/__________/public_html/wp-content/plugins/gp-premium/library/EDD_SL_Plugin_Updater.php on line 323

    ____________ = the account name on the hosting platform so is different in each site.

    Any idea what’s causing this?

    URL in the website field is a site that is having this and several other issues but I’ve also seen this on sites that are otherwise fine.

    #926080
    Tom
    Lead Developer
    Lead Developer

    Strange, we haven’t received reports of this before. It’s basically saying it doesn’t know the name of the plugin folder.

    Are your GP Premium updates working?

    #926083
    Scott

    I’ll have to check next time there is an update. It is up-to-date now but not sure when we last updated v. when the error started getting logged.

    #926377
    Tom
    Lead Developer
    Lead Developer

    If you’re comfortable with changing core files, you can open gp-premium.php (Plugins > Editor) and change the version number to something like 1.7. This will trigger the update system to bring you back to 1.8.2.

    #926423
    Scott

    I changed version to 1.7 and it prompted for update which succeeded. But … this site is now on a different host due to immense frustration with and incompetence by the support at a certain widely advertised hosting service so too many variables may have changed at once to see this one through … there’s no error file being generated on the new host.

    We can drop this for now. If I see it again on this or another site I’ll let you know.

    #926534
    Tom
    Lead Developer
    Lead Developer

    Sounds good – thank you! 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.