[Support request] Permalink Problem

Home Forums Support Permalink Problem

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #411732
    johnzoro

    Hi guys,

    On my website greatest reviews i normally have the url then the slug

    so it would be like greatest reviews .co. uk /name-of-post/

    this seems to be fine for all of my posts, except this one post i’m working on

    whenever i try and set the slug to name-of-post it always adds a 2 at the end.

    Now i know this is because there is probably something else using that like an image or another post, so i checked and deleted all images relating to that keyword and there were no other posts.

    There were also no other catergories or tags.

    I then went into phpmyadmin and went to wp_posts and found it in there and deleted it.

    This seemed to work…. or so i thought.

    I created a draft post now and when i try and set the slug to name-of-post it adds a 14 to the end of it

    The only thing i can think of is maybe the sections are getting slugs/permalinks?

    Any ideas?

    GeneratePress 1.4
    #412026
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That can happen when a post with the same name is in the trash – have you looked in there? Once you empty your trash, it should be available again.

    #412031
    johnzoro

    Its not in trash

    #412145
    Tom
    Lead Developer
    Lead Developer

    Hmm, so here’s the only ways that I know of that can cause this.

    1. Another post/page/attachment (media library)/custom post type item with the same permalink.
    2. An item in the trash (within any of the above) with the same permalink.

    If that’s not the case, you either have an issue with your database, or a plugin rewriting permalinks that has a bug.

    #412224
    johnzoro

    it only happens on one particular post.

    like i mentioned earlier, i checked all my posts, pages, catergories and media and deleted everything related to that post

    I even went into phmyadmin and deleted all the rows in there in wp_posts

    This did make it work for a bit

    I had it as post-name-here but because my post name was keyword 2017 the ultimate guide, it changed my slug to post-name-here-2017-ultimate guide

    i didn’t notice this until after i’ve written some content then i tried to change it back but it wasn’t have any of it and added -14 to the end?

    #412229
    johnzoro

    oh something else i thought of was maybe it could be a “back up” of the post

    #412314
    johnzoro

    #412315
    johnzoro

    ok it looks good in phpmyadmin but still comes up with a number at the end in wordpress

    #412459
    Tom
    Lead Developer
    Lead Developer

    So that screenshot says there’s a draft with the same permalink. Has it been permanently deleted (not just sent to trash)?

    If none of that is working, you might need to check with WordPress.org support, as this is core WordPress functionality. Maybe they’ve seen the issue before.

    #412655
    johnzoro

    that post in phpmyadmin is the post i am currently working on

    it says it’s ok in phpmyadmin but in wordpress it adds a number to the end

    ok seperate issue, but possibly related

    sometimes when i update the title of sections, it updates the title of the post to the title of the last section i worked on

    any ideas why this is happening too?

    #412663
    johnzoro

    i just added 2017 to the end. no idea why this is happening

    #412712
    Tom
    Lead Developer
    Lead Developer

    Best to stick to one issue per thread. If you can create a new topic for that separate issue, that would be great!

    I’m not sure what you mean by adding 2017 to the end? Have you reported this to WordPress support yet? They see a lot of issues every day, so maybe this has come up before and they have a solution I’m not aware of.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.