Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Pages do not load after adding an image to page header and hard crop enabled

Home Forums Support Pages do not load after adding an image to page header and hard crop enabled

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #65218
    Reinhold Schneider

    Hi Tom!
    I got a strange problem.
    When I add an image to the page header and enable hard crop the page does not load fully. Neither as a preview nor when I publish it.
    It stops after loading the header, navigation and title and before loading the page header image, widgets and all the rest of the page.
    With hard crop disabled everything works and the page shows up completely, but that’s not what I need.
    This did not happen before and I’m not sure, when it started and why.
    Everything I published before still works fine, but nothing new does.
    Any suggestions?
    Regards
    Reinhold

    #65222
    Reinhold Schneider

    The problem is the same on two different sites, running on different servers!
    Just checked.

    #65249
    Tom
    Lead Developer
    Lead Developer

    Hi Reinhold,

    Can you try enabling WP_Debug and let me know if any errors show up? http://codex.wordpress.org/WP_DEBUG

    Your servers might not allow WordPress to change the image (permission issues).

    Let me know 🙂

    #65318
    Reinhold Schneider

    Hi Tom!

    Thanks for your answer!
    It seems to be a bug in a plugin, I think:

    Fatal error: Call to undefined method EWWWIO_Imagick_Editor::opacity() in
    /var/www/web3428/html/Reisen-heilt/wordpress_reisen-heilt/wp-content/plugin
    s/gp-premium/addons/generate-blog/inc/bfi_thumb.php on line526

    When I deactivate the plugin, hard crop and the header image work.
    Should I contact them and see, whether they get it going?
    Or is it something you would have to adjust in GeneratePress?

    Best regards
    Reinhold

    #65503
    Tom
    Lead Developer
    Lead Developer

    Hmm, the newest update (coming very soon) may fix this – looks like your server is missing some settings.

    Can you contact your host and make sure either Imagick or the GD library are installed on your server (they’ll know what that means).

    Let me know 🙂

    #67032
    Reinhold

    Hi Tom!
    They suggest to try another php-version.
    That’s all from them.
    Maybe it’s just and only a problem with the plugin (EWWW Image Optimizer).
    You could install it and see whether it works – or not 😉
    Best regards,
    Reinhold

    #67156
    Tom
    Lead Developer
    Lead Developer

    I just installed that plugin and hard cropped an image – didn’t seem to have any issue.

    Maybe it’s the settings you have enabled in the plugin? Maybe bring things back to stock?

    #67306
    Reinhold

    Hi Tom!
    We didn’t change the settings of the plugin.
    Maybe the problems came with its last update, I’m not sure.
    So, we’ll see and “work around that issue” until it vanishes again…

    #67396
    Tom
    Lead Developer
    Lead Developer

    Very odd – so it works perfectly when that plugin is deactivated?

    Hopefully the next update fixes this – it’s finally ready to be released 🙂

    #67402
    Reinhold

    That’s right, everything’s ok, when the plugin is deactivated.

    #67565
    Tom
    Lead Developer
    Lead Developer

    I’ll run some more tests, but I’m going to assume it’s a server thing if it works for me and not for you.

    Let me know if you find out anything more 🙂

    #67662
    Reinhold

    They said again, it must be the php-version and I should try another.
    That’s odd, too 😉

    #67743
    Tom
    Lead Developer
    Lead Developer

    Are they not willing to upgrade their version of PHP? Very weird..

    #67801
    Reinhold

    5.4 is running by default.
    5.3, 5.5 and 5.6 are possible, too.

    #68084
    Tom
    Lead Developer
    Lead Developer

    Hmm, shouldn’t actually make a difference. Let’s see how the new version works with it once I release it 🙂

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.