Premium support

Please log in to post in these forums. If you didn't create an account when you purchased, please contact us.

Free support

If you haven't purchased GP Premium, support for the free theme can be found on WordPress.org.

[Resolved] Page Title changing to Section Name

Home Forums Support Page Title changing to Section Name

This topic contains 8 replies, has 2 voices, and was last updated by  Tom 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #365019

    Hi,

    Something odd happening here.

    When I click on Pages – Edit, I’m presented with my home page, the only page on my site at the moment. The page uses Sections. So far so good. However, then this message pops up, every time:

    The backup of this post in your browser is different from the version below. Restore the backup
    This will replace the current editor content with the last backup version. You can use undo and redo in the editor to get the old content back or to return to the restored version.

    When I click on the ‘Restore the backup’ button, the page refreshes, and oddly my page Title changes from ‘Blah blah blah’, to just ‘Intro’, which is the name/title of the second Section in my page. The only way to get the true Title of the page to display again is to click on, for example, Media, and then navigate back to Pages, and all is good again. When I click on Media or any other link, a wp dialog asks me if I want to Stay or Leave the page I’m on.

    Is this normal behaviour, seems odd?

    I’m new to wp, as you can probably tell 🙂

    Thanks
    Steve

    GP Premium 1.4.2
    #365024

    Tom
    Lead Developer
    #365510

    Hi Tom,

    Doesn’t appear to be a browser issue…. I use Chrome, but I get the same effect in Opera too, the only difference being that Opera changed the page Title and it remains changed, even when I navigate away from Pages and back again.

    I’ll try debug and come back to you.

    Thanks
    Steve

    #365558

    Hi Tom,

    WP allowed me to change the page Title from ‘Intro’ (a section name) back to the original Title/page name, but after editing a few Sections the ‘Restore the backup’ button came back. When I clicked on the button the name changed back to Intro again.

    I changed the Title back to the original name again. However, after a few more edits and viewing the page in the browser, WP displayed the autosave link and the Restore button. I clicked on the autosave link, my original page name on the left, and Intro displayed on the right. When I selected autosave, the Title changed back to Intro.

    I tried the debug option and deactivated all plugins, which made no difference, same issues.

    When activated, I only use WordFence, Sucuri, Yoast SEO and GP P.

    Thanks
    Steve

    #365763

    Tom
    Lead Developer

    What happens if you just ignore the restore message? Are you able to continue editing/publish/update?

    #365832

    Yes, I can still edit, publish and update.

    If I clear the browser cache and login to WP, I receive the Restore message after editing a few sections. If I close the message it just reappears after a few more Section edits.

    Whether I publish/update or not, after editing, makes no difference, the message keeps reappearing.

    #366110

    Tom
    Lead Developer

    Strange, I’ll see if it has anything to do with Sections.

    For now, best to just ignore it and keep on editing your page.

    #367769

    Hi Tom,

    I’ve researched this issue extensively and pin-pointed the following as the most likely causes:

    1. Theme issue
    2. Internet connection issue

    If no one else has reported this issue to you, then I would go with 2. Although my connection is reasonable, there has been a slow-down recently.

    However, the issue has largely been resolved, I think/hope. I’m not sure what fixed it, but the message rarely appears now. I did all of the following on the same day so I don’t know which one fixed it, it was either:

    1. the latest theme update
    2. rebooting my router
    3. adding the following code to the wp-config file

    # BEGIN Disable post revisions
    define(‘AUTOSAVE_INTERVAL’, 300); // seconds
    define(‘WP_POST_REVISIONS’, false);
    # END Disable

    The renaming of the page Title to a Section name is weird, but hey so is life sometimes 🙂

    Thanks
    Steve

    #368024

    Tom
    Lead Developer

    Thanks for reporting back! I’ll keep an eye out for the issue as well in case it is something to do with Sections.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.