[Support request] Page is not mobile friendly

Home Forums Support Page is not mobile friendly

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1306761
    Jeffrey

    Geting this error:

    Content wider than screen

    Clickable elements too close together

    Text too small to read

    Already installed Autoptiize (which is sort of annoying to have to install a third-party plugin to fix the theme). It doesn’t work.

    What to try next?

    Thx

    #1307087
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Something is up with the way your resources are loading – at least in the Google mobile test. Can you try the test again without any caching/minifying plugins?

    which is sort of annoying to have to install a third-party plugin to fix the theme

    What is it fixing?

    #1307513
    Jeffrey

    Thanks for this response.

    Sorry I had read somewhere on this forum to add autoptimize to fix.

    I disabled these plugins and now getting that “Page is mobile friendly”.

    Thanks; however, now getting this error: https://prnt.sc/sqm901

    Thx

    #1307929
    Tom
    Lead Developer
    Lead Developer

    Autoptimize is a great plugin that does a lot of cool things that a theme shouldn’t do – it’s all plugin territory stuff.

    Perhaps re-activate it and then follow our recommended settings on this page: https://generatepress.com/fastest-wordpress-theme/

    That should help with the number of resources you have.

    #1313085
    Jeffrey

    Autoptimze does not work it breaks my site.

    What kind of theme requires a dumb plugin to work?

    Propose a different site fix please or issue me a refund. Thank you.

    #1313324
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    It’s not required, it just helps reduce the number of resources your site loads. We’re using it here on this website.

    The error you’re trying to fix is the fact that your site is loading 76 resources. The theme itself only loads 3-4 depending on your settings – the rest are coming from other plugins you’re using.

    If you want to reduce the number of requests, you need to use a caching/minifying plugin, which will combine all of those files into 1 or 2 requests. Either that or you need to choose plugins that load fewer resources.

    Autoptimize is just one plugin that does that. There are countless other caching/minifying plugins out there that serve exactly this purpose.

    Of course, feel free to shoot us an Account Issue email if you’d like a refund: https://generatepress.com/contact

    Thanks!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.