[Resolved] Padding issue for mobile browsers

Home Forums Support Padding issue for mobile browsers

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #914181
    Tony

    Hi,

    Wanted to follow up on another thread I found, but thought it’d better not to necro it and post my own. The thread is ticket #724829.

    I have the same settings as OP in that topic, but the thing is I want to be able to continue using Autoptimize to minify the site CSS as it helps with the page speed somewhat. For website design reasons I’d also like to continue to use the masonry grid for a 2 column layout and 1st post featured.

    Unfortunately applying the CSS fix in that topic didn’t help, so I removed it. I would appreciate any further help!

    Thanks,
    Tony

    #914188
    David
    Staff
    Customer Support

    Hi there,

    so if you uncheck Combine CSS does the problem go away?
    As you’re server is running HTTP 2.0 – i would expect that having combined CSS won’t make any noticeable difference. Let me know.

    #914192
    Tony

    Hi David,

    Thanks for the reply.
    I can confirm that I need to uncheck the option “Aggregate CSS-files?: Aggregate all linked CSS-files? If this option is off, the individual CSS-files will remain in place but will be minified.” for the issue to go away.

    Unchecking “Also aggregate inline CSS?” alone isn’t enough.

    I’ve disabled “Aggregate CSS-files” for now, if you want to take a look.

    #914225
    David
    Staff
    Customer Support

    Looks good to me – you may need to clear browser caches and resize your browser if it still looks out of sorts.

    No aggregate inline CSS won’t work as this is only for inline styles which we don’t use in the theme.

    Worth trying a speed test with and without the option enabled. It loaded fast for me.

    #914234
    Tony

    Hi,

    Yes it’s because the problem setting was disabled. The changes are immediately apparent everytime I toggle the setting on or off.

    And for the comparison, I did lose about ~20 in mobile page speed insights.

    Wondering if there’s a way to force the padding to behave, else I’ll have to live with either a mildly slower page or an off centred mobile experience. Not too bad either way it just pokes at my OCD.

    #914438
    David
    Staff
    Customer Support

    You could try leaving the option on and add this to Exclude field:

    wp-content/plugins/gp-premium/blog/functions/css/

    If not, i wouldn’t be too bothered about the pagespeed rating as long as it hasn’t significantly impacted the pagespeed. HTTP 2.0 removes the limit on how many requests can be made simultaneously – so having lots of little files being loading at the same time can sometimes outweigh one large combined file…..

    #914872
    Tony

    Hi David,

    I agree with the pagespeed and thanks for the workaround. I’ll implement it for now and mark this as solved.

    Thanks for all the help!
    Tony

    #914879
    David
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.