[Resolved] Optimize website for maximum speed capability

Home Forums Support Optimize website for maximum speed capability

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #1380468

    Until yesterday I was using W3 total cache plugin for cashing due to which I was getting 2.5 seconds of speed with 47 HTTP requests.

    Today I was checking support forms for increasing more speed, there Mr.Tom suggested to use Autopimize plugin for caching. So I disabled W3 cache & installed autoptimize. After Installing Autopimize my website speed increased from 2.5 seconds to 1.5 seconds. moreover, and my HTTP requests went down 25.

    BUT, I have linked my w3 total cache with Cloudfare, yoast seo and AMP. So I took a risk and enabled w3 total cache & started using W3 with autopitimize. I didn’t change any settings & I was using JS & CSS compression in both plugins. Surprisingly, The website speed increased even more but HTTP request increased by 2. Right now I am getting speed BELOW 1 SECOND.

    I thought my website would crash, as using more than 1 cache plugin creates many problems. Last time I had to restore my website from backup because I used W3 lazy load option with lazy loading plugin. I was getting 500 internal server error on both wp-admin panel and website.

    I am getting surprisingly better speed by using both. My website might create 500 internal server error in future, but I am taking the risk and see what happens. now I am continuing my experiments with both plugin and see which setting will provide most speed and which setting will decrease my speed.

    So do you have any suggestion so that I can use both plugins without getting a problem?

    Customer Support

    Hi there,

    i would recommend asking Frank at Autoptimize this question. He is very knowledgable and helpful and has a lot more insight on how his plugin behaves with a cache plugin installed.



    okay, then I’ll ask the developer… thanks for the info

    Customer Support

    You’re welcome. Franks a good guy πŸ˜‰


    You really are a funny person… haha.

    Anyway, I found a way to use W3 total cache with autoptimize and it increases performance even more. Not only I got almost perfect score in google page speed inside but my gtmetrix scores were also drastically imrpoved. Now I am getting an AVERAGE speed between 0.8 sec to 1.8 seconds depending on the country.

    To solve the issue of using 2 cache plugin I checked everywhere and I found that, if settings of 2 cache plugin with similar function activate together, any website will crash. In my case, my website was creating “500 internal server error”.

    “W3 TOTAL CACHE” & “AUTOPTIMIZE” HAS SAME HTML COMPRESSION TECHNIQUE. (here I am not going into details of the specific process used by both cache plugin for HTML compression)

    Plus, W3 total cache has a bug in its HTML compression so it hinders with other plugins, even if we uncheck the HTML compression it will still create weird problems depending on the website. W3 total cache tried to fix that HTML compression in the last update but the bug has not been fixed properly, and w3 total cache still working in the issue.

    Now the question is how I am able to optimize both plugins without a glitch?

    It took me almost 12 hr to figure out this thing. Here, I tweaked a few things –

    1) In General Settings – under minify section – I enabled minify & set it to mode manual.

    2) under browser section – I enabled browser cache

    3) In minify settings – I unchecked all options under HTML & XML section

    4) for JS SECTION & CSS SECTION – I added all CSS & JAVA SCRIPTS using help wizard in top of “all” the section in the page (I excluded the CSS & JS which was controlling my custom CSS) (I wasn’t able to figure out which scripts were for custom CSS, so I checked every option whichever were related to plugins and excluded the rest. this way I was able to figure out the scripts related to custom CSS)

    5) I enabled preserved comment removal & line break removal and Also enable HTTP/2 push under both JS
    & CSS section.

    6) In-Browser cache settings, under general section – I unchecked all options except “Remove query strings from static resources”

    7) under CSS & JS section I checked all options except “Prevent caching of objects after settings change” & “Disable cookies for static files”

    8) again in HTML & XML section i unchecked everything.

    9) I installed autoptimizer and didn’t bother to change default settings as those are already optimized to most websites.

    IF the problem remains even after settings all these things. I think by removing html compression in autoptimiser will solve the issue because W3 has a bug in HTML compression which continue running even after disabling.

    ( there are lot more things I set but those configurations are for my own personal preference and for plugins I am using, so i am not including those)

    Please share this with anyone who need to improve speed.

    I bought hosting plan in last month and it took me this much time just to optimize my webiste.

    Customer Support

    Wow – thanks for taking the time to share your findings. I am sure others will find them useful πŸ™‚


    thanks. I have found that Your team always goes an extra mile to help those who need suggestion outside of Generatepress. So I thought maybe I should contribute to this forum too.

    Anyway, If any kind of problem appears due to these settings I’ll share the information here and let you know.

    Lead Developer
    Lead Developer

    Thank you! We appreciate it πŸ™‚

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.