[Resolved] Not able to import demo site – Hostgator limits cannot be changed

Home Forums Support [Resolved] Not able to import demo site – Hostgator limits cannot be changed

Home Forums Support Not able to import demo site – Hostgator limits cannot be changed

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #656595
    Patricia

    Hi;

    When importing Aspire I get a 500 Internal server error.

    I’ve searched the forum and found this info:

    The following server settings can be increased to better allow GP to upload and process the import files.
    upload_max_filesize (256M)
    max_input_time (300)
    memory_limit (256M)
    max_execution_time (300)
    post_max_size (512M)

    But Hostgator can’t increase limits on shared hosting:
    https://support.hostgator.com/articles/php-settings-that-cannot-be-changed

    Unless I move the account to VPS or Dedicated Server, which I wouldn’t do just because of a demo site, we won’t be able to import.

    They’ve also installed php-xml but still not working.

    Any other way to upload the demo theme? Is it on some sort of .zip file I could upload?

    Please help.

    Thanks

    Patri

    GeneratePress 2.1.4
    #657048
    Tom
    Lead Developer
    Lead Developer

    Oh Hostgator..

    Can you try the Further Debugging step here?: https://docs.generatepress.com/article/error-codes-importing/#further-debugging

    It will allow us to know exactly what issue your server is running into.

    Let me know 🙂

    #658636
    Patricia

    Thanks.

    I’ve added these two lines to wp-config.php:

    define( ‘WP_DEBUG’, true );
    define( ‘WP_DEBUG_LOG’, true );

    Not sure how to proceed now. Is this something you do from your end?

    Thanks again.

    Patri

    #658858
    David
    Staff
    Customer Support

    Hi there,

    If you can follow this part of the debugging guide, by accessing your server over FTP or asking your host for assistance:

    Now you’ll find a file named debug.log in the wp-content folder on your server. Open this file, and look at the end for any errors.

    #659130
    Patricia

    Ok, I spoke to Hostgator as I couldn’t find debug.log but they told me error_log would be the one to look for.

    I found it and opened it, here’s what it says:

    [06-Aug-2018 23:11:45 UTC] PHP Warning: require_once(/home1/name/public_html/wp-content/plugins/wpforms-lite/includes/class-frontend.php): failed to open stream: No such file or directory in /home1/name/public_html/wp-content/plugins/wpforms-lite/wpforms.php on line 311
    [06-Aug-2018 23:11:45 UTC] PHP Fatal error: require_once(): Failed opening required ‘/home1/name/public_html/wp-content/plugins/wpforms-lite/includes/class-frontend.php’ (include_path=’.:/opt/php55/lib/php’) in /home1/name/public_html/wp-content/plugins/wpforms-lite/wpforms.php on line 311
    [06-Aug-2018 23:11:45 UTC] PHP Fatal error: Call to undefined function is_user_logged_in() in /home1/name/public_html/wp-content/mu-plugins/endurance-page-cache.php on line 370

    Is this what you need?

    #659196
    Leo
    Staff
    Customer Support

    Tom will be away until later today.

    What happens if you disable the plugins that were mentioned in the errors above?

    #659288
    Patricia

    I did what you suggested but still, I get the 500 Internal Server Error.

    #659289
    Patricia

    Success. I disabled all plugins except GeneratePress, Elementor and WP Posts.

    No idea which one was causing the error, but it worked.

    Thanks everyone.

    Patri

    #659319
    Leo
    Staff
    Customer Support

    Glad we could help 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.